Car won't start periodically. Immobilizer problems. Code: P1693 - New Tiburon Forum : Hyundai Tiburon Forums
 
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 17 Old 11-10-2014, 03:35 PM Thread Starter
NewTiburon.com Newbie
 
Join Date: Sep 2012
Location: Canada
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JimboSlyce5 is an unknown quantity at this point
(Thread Starter)
Car won't start periodically. Immobilizer problems. Code: P1693

'04 4cyl 5spd Canadian tib with immobilizer

The other week my car started up for 1 whole second, then died. Then it would only crank and not fully start. I left it for a few hours and all was fine, started up just fine. It has been doing randomly for the last couple weeks now.
I took it in to get it fixed because I don't want to end up stranded somewhere when it doesn't feel like starting. They got the code P1693 which is the immobilizer transponder. The dealer said it could be a number of things and they would need to diagnose it first. So now I'm wondering a few things:

Has anyone had this code come up for them before?

What needed to be done to fix it?

Is there anything I can do myself to fix it? (I'm good with my hands but far from a mechanic)

I'm going to get a remote starter system put in soon, can I just bypass the immobilizer and ignore all of this?
JimboSlyce5 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 11-10-2014, 03:57 PM
NewTiburon.com Novice
 
airkix72's Avatar
 
Join Date: May 2014
Location: Detroit, MI
Posts: 231
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
airkix72 has a spectacular aura aboutairkix72 has a spectacular aura about
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by JimboSlyce5 View Post
I'm going to get a remote starter system put in soon, can I just bypass the immobilizer and ignore all of this?
I bought a supercharger that came out of a canadian tib, he gave me an ECU and a bypass he used. It's called PKALL from directed electronics and it might solve your problem. I don't have an immobilizer so I never tried it out. good luck

PKALL PKALL


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.

My 2 Tibs, Yellow 04 GT SE auto "The DD" and the black 03 GT 6spd, The "I learned to be a mechanic" car
To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.

I am gathering all the files related to the Tib and hosting them, if you have a file I don't please PM me and I will host it.

To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.

Last edited by airkix72; 11-10-2014 at 04:00 PM.
airkix72 is offline  
post #3 of 17 Old 11-10-2014, 11:00 PM
NewTiburon.com God
 
maze1291's Avatar
 
Join Date: Feb 2011
Location: Hamilton, Ontario
Posts: 2,247
Mentioned: 38 Post(s)
Tagged: 0 Thread(s)
maze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of light
Garage
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by airkix72 View Post
I bought a supercharger that came out of a canadian tib, he gave me an ECU and a bypass he used. It's called PKALL from directed electronics and it might solve your problem. I don't have an immobilizer so I never tried it out. good luck

PKALL
The PKALL requires a matching immobilizer code from the key as it reads the code from the key in the programming process and will repeat it and send it to the ECU when given the start command.

OP. I'm wondering if this is an issue with your transponder antenna. This is a small spool of copper wire housed in a plastic enclosure that sits at the end of your column/key lock.

I can't speak from personal experience on this matter. If you have a second key it would be good to know if you're experiencing the same issue on the second key.


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
Breaking things is just an opportunity to make them better.
maze1291 is offline  
 
post #4 of 17 Old 11-11-2014, 12:36 AM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by JimboSlyce5 View Post
'04 4cyl 5spd Canadian tib with immobilizer

The other week my car started up for 1 whole second, then died. Then it would only crank and not fully start. I left it for a few hours and all was fine, started up just fine. It has been doing randomly for the last couple weeks now.
I took it in to get it fixed because I don't want to end up stranded somewhere when it doesn't feel like starting. They got the code P1693 which is the immobilizer transponder. The dealer said it could be a number of things and they would need to diagnose it first. So now I'm wondering a few things:

Has anyone had this code come up for them before?

What needed to be done to fix it?

Is there anything I can do myself to fix it? (I'm good with my hands but far from a mechanic)

I'm going to get a remote starter system put in soon, can I just bypass the immobilizer and ignore all of this?
mine does this as well. happens maybe once a week but I found a small button in my fuse panel connected to some wires. don't ask me how I happened to figure it out but when my car went into immobilzer mode it would just turn over. so I held down the button and heard a click noise in the dash and tried the ignition and it fired right up. It happened enough that I drilled a hole beside the fuse panel and mounted the button on the face of the dash so I could press it when needed instead of popping the fuse panel all the time. maybe look in your fuse panel and see if you have one too?
xtremevert is offline  
post #5 of 17 Old 11-11-2014, 01:23 AM
NewTiburon.com God
 
oni888's Avatar
 
Join Date: May 2013
Location: ravenna ohio
Posts: 1,863
Mentioned: 102 Post(s)
Tagged: 0 Thread(s)
oni888 has a spectacular aura aboutoni888 has a spectacular aura aboutoni888 has a spectacular aura about
Re: Car won't start periodically. Immobilizer problems. Code: P1693

the transponder itself is mounted in the top portion of the ignition key. is there a battery in it maybe?(not the one in the FOB) isnt there some light on the instrument panel that shows a key into a car type thingy? does that light up? another member is having same/similar problem.

Wife's car: 2008 GS, L4 AT Hypersilver. all Tuscani trim. metal silver trim plates, door handles, pulls and center fascia, some leather and many cat fur festooned interior parts. burn hole on rear seat along with stuffed kitty "Lucky." Traded 2/25/16 for a 2012 Black Kia Soul+, 2.0 L4@165HP, 6speed auto. 42k miles, all bells and whistles. no Gerbils(or Hamsters) but stuffed kitty "Lucky" has back seat (no burn hole)all to himself.

Last edited by oni888; 11-11-2014 at 01:27 AM.
oni888 is offline  
post #6 of 17 Old 11-11-2014, 10:42 AM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by oni888 View Post
the transponder itself is mounted in the top portion of the ignition key. is there a battery in it maybe?(not the one in the FOB) isnt there some light on the instrument panel that shows a key into a car type thingy? does that light up? another member is having same/similar problem.
That's what happens on my car. The car with the key light pops up on the instrument panel then I press the button, it clicks and the car starts. Am I the only one who has this button inside my fuse box? It looks like it's a standard over ride switch from factory?

Last edited by xtremevert; 11-11-2014 at 10:44 AM.
xtremevert is offline  
post #7 of 17 Old 11-11-2014, 10:43 AM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by xtremevert View Post
That's what happens on my car. The car with the key light pops up on the instrument panel then I pres the button, it clicks and the car starts. Am I the one who this button inside my fuse box? It looks like it's a standard over ride switch from factory?
xtremevert is offline  
post #8 of 17 Old 11-11-2014, 11:50 AM
NewTiburon.com God
 
oni888's Avatar
 
Join Date: May 2013
Location: ravenna ohio
Posts: 1,863
Mentioned: 102 Post(s)
Tagged: 0 Thread(s)
oni888 has a spectacular aura aboutoni888 has a spectacular aura aboutoni888 has a spectacular aura about
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by xtremevert View Post
That's what happens on my car. The car with the key light pops up on the instrument panel then I press the button, it clicks and the car starts. Am I the only one who has this button inside my fuse box? It looks like it's a standard over ride switch from factory?
maybe the OP will look and see if there is one of those switches. US Tibs dont have immobilizers. i have read elsewhere that later model Santa Fe's have them and probably other Hyundais.

Wife's car: 2008 GS, L4 AT Hypersilver. all Tuscani trim. metal silver trim plates, door handles, pulls and center fascia, some leather and many cat fur festooned interior parts. burn hole on rear seat along with stuffed kitty "Lucky." Traded 2/25/16 for a 2012 Black Kia Soul+, 2.0 L4@165HP, 6speed auto. 42k miles, all bells and whistles. no Gerbils(or Hamsters) but stuffed kitty "Lucky" has back seat (no burn hole)all to himself.
oni888 is offline  
post #9 of 17 Old 11-11-2014, 12:49 PM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by oni888 View Post
maybe the OP will look and see if there is one of those switches. US Tibs dont have immobilizers. i have read elsewhere that later model Santa Fe's have them and probably other Hyundais.
seriously huh? what is the point of them? I know my Nissan Titan has one as well but this is only a Canadian vehicle thing? I guess is law up here or something?
xtremevert is offline  
post #10 of 17 Old 11-11-2014, 03:40 PM Thread Starter
NewTiburon.com Newbie
 
Join Date: Sep 2012
Location: Canada
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JimboSlyce5 is an unknown quantity at this point
(Thread Starter)
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by oni888 View Post
maybe the OP will look and see if there is one of those switches. US Tibs dont have immobilizers. i have read elsewhere that later model Santa Fe's have them and probably other Hyundais.
I looked and didn't seem to have this button. Maybe I'm not looking in the right spot? Sounds like it should be pretty easy to spot in the panel though.
JimboSlyce5 is offline  
post #11 of 17 Old 11-11-2014, 03:44 PM Thread Starter
NewTiburon.com Newbie
 
Join Date: Sep 2012
Location: Canada
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JimboSlyce5 is an unknown quantity at this point
(Thread Starter)
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by maze1291 View Post
The PKALL requires a matching immobilizer code from the key as it reads the code from the key in the programming process and will repeat it and send it to the ECU when given the start command.

OP. I'm wondering if this is an issue with your transponder antenna. This is a small spool of copper wire housed in a plastic enclosure that sits at the end of your column/key lock.

I can't speak from personal experience on this matter. If you have a second key it would be good to know if you're experiencing the same issue on the second key.
After doing research, it seems like the transponder antenna is usually the problem in these cases. Have you had to deal with the antenna before? Is it an easy fix?

I have switched to my spare key, but fortunately my car has been starting for me again.
JimboSlyce5 is offline  
post #12 of 17 Old 11-11-2014, 09:52 PM
NewTiburon.com God
 
oni888's Avatar
 
Join Date: May 2013
Location: ravenna ohio
Posts: 1,863
Mentioned: 102 Post(s)
Tagged: 0 Thread(s)
oni888 has a spectacular aura aboutoni888 has a spectacular aura aboutoni888 has a spectacular aura about
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by xtremevert View Post
seriously huh? what is the point of them? I know my Nissan Titan has one as well but this is only a Canadian vehicle thing? I guess is law up here or something?
its an "anti-theft"device as far as i know. the US Tibs rely on the remote lock and alarm thing on the key fob. (thats why we are all scratching our ass trying to help, we dont have the immobilizer.) i once couldnt get the doors to unlock in winter so i went in thru the trunk and manually unlocked the doors. when i went to start the car, all hell broke loose. doors relocked, ignition wouldnt turn, steering wheel and shifter locked down and horns basted and lights blinked til i relocked everything with the fob then unlocked the car with the fob. i damn near "soiled my skivvies" had i been wearing any! anyway, looking for more info on this immobilizer deal, i did read on some other forums that other Hyundai models starting in 08, i think, do have them, maybe as an option, maybe standard. personally i have yet to hear of any.
the Comprehensive Service Manual you can download on this site does have the wiring diagram for the immobilizer along with other stuff not available, like headlight adjusters.

Wife's car: 2008 GS, L4 AT Hypersilver. all Tuscani trim. metal silver trim plates, door handles, pulls and center fascia, some leather and many cat fur festooned interior parts. burn hole on rear seat along with stuffed kitty "Lucky." Traded 2/25/16 for a 2012 Black Kia Soul+, 2.0 L4@165HP, 6speed auto. 42k miles, all bells and whistles. no Gerbils(or Hamsters) but stuffed kitty "Lucky" has back seat (no burn hole)all to himself.

Last edited by oni888; 11-11-2014 at 10:01 PM.
oni888 is offline  
post #13 of 17 Old 11-11-2014, 11:07 PM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by JimboSlyce5 View Post
I looked and didn't seem to have this button. Maybe I'm not looking in the right spot? Sounds like it should be pretty easy to spot in the panel though.
it was actually kind of to the right within the wires kinda hanging there.
xtremevert is offline  
post #14 of 17 Old 11-12-2014, 02:24 PM
NewTiburon.com Novice
 
Join Date: Aug 2013
Location: Sherwood Park, Alberta
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
xtremevert is an unknown quantity at this point
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by xtremevert View Post
it was actually kind of to the right within the wires kinda hanging there.
maybe I'll take a picture of it tonight to show you what it looks like while my tib is still in the garage.
xtremevert is offline  
post #15 of 17 Old 11-12-2014, 09:22 PM
NewTiburon.com God
 
maze1291's Avatar
 
Join Date: Feb 2011
Location: Hamilton, Ontario
Posts: 2,247
Mentioned: 38 Post(s)
Tagged: 0 Thread(s)
maze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of lightmaze1291 is a glorious beacon of light
Garage
Re: Car won't start periodically. Immobilizer problems. Code: P1693

There is no battery in the key itself.

Just so you know I happen to have a spare transponder receiver around from my parts car a few years back. It worked when it came off the car. If interested feel free to shoot me a PM.

Can't say for certain whether it would solve your issue or not. But if you feel it's worth a try I'll help you out!


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
Breaking things is just an opportunity to make them better.
maze1291 is offline  
post #16 of 17 Old 11-13-2014, 02:06 AM Thread Starter
NewTiburon.com Newbie
 
Join Date: Sep 2012
Location: Canada
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JimboSlyce5 is an unknown quantity at this point
(Thread Starter)
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by maze1291 View Post
There is no battery in the key itself.

Just so you know I happen to have a spare transponder receiver around from my parts car a few years back. It worked when it came off the car. If interested feel free to shoot me a PM.

Can't say for certain whether it would solve your issue or not. But if you feel it's worth a try I'll help you out!
That's awesome. I will wait to see what the dealer diagnoses it as and may take you up on that offer. I appreciate it.
JimboSlyce5 is offline  
post #17 of 17 Old 11-13-2014, 02:07 AM Thread Starter
NewTiburon.com Newbie
 
Join Date: Sep 2012
Location: Canada
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JimboSlyce5 is an unknown quantity at this point
(Thread Starter)
Re: Car won't start periodically. Immobilizer problems. Code: P1693

Quote:
Originally Posted by xtremevert View Post
maybe I'll take a picture of it tonight to show you what it looks like while my tib is still in the garage.
Ya, hey if you got the time to do it then that would be great. I will have another looksy myself in the morning tomorrow.

You guys are all awesome on here.
JimboSlyce5 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the New Tiburon Forum : Hyundai Tiburon Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome