OBD-II port useless - New Tiburon Forum : Hyundai Tiburon Forums
 

Go Back   New Tiburon Forum : Hyundai Tiburon Forums > GK Performance (03+) > I4 - Naturally Aspirated
NewTiburon.com is the premier Hyundai Tiburon Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
Thread Tools Display Modes

#1
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old OBD-II port useless 05-18-2011 , 12:01 PM

I have a 2004 2.0L CVVT Tiburon... I've tried with several OBD-II tools (known good tools) and I cant manage to get a reading.

I currently own a ELMSCAN5... Tried with all sort of different softwares including SCAN XL.... no go.

Now I got a Equus 3130 scan tool.... Doesnt work. Tried it last night on a friends 1996 Neon and it worked flawlessly...

On mine... It tries to link... says... Detecting protocol.... ISO 9141.... Link 2000 and BAM... disconnected... Connection has been lost with the vehicle...

I've been reading about OBD-II port recalls, but the most detailed info I found was realted to 2002 V6 Euro Tibs with Inmobilizer....

BTW I've never been able to use the OBDII port....

Is it the ECU? Wiring harness? Port? Pins? Haunted car?

Cheers!
    Reply With Quote Quick reply to this message  

Sponsored Links
Advertisement
 

#2
Shark2005
NewTiburon.com God


Shark2005 is offline

Shark2005's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Sex: Male
Posts: 1,731
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Shark2005 is a glorious beacon of lightShark2005 is a glorious beacon of lightShark2005 is a glorious beacon of lightShark2005 is a glorious beacon of lightShark2005 is a glorious beacon of lightShark2005 is a glorious beacon of light

Old Re: OBD-II port useless 05-18-2011 , 12:21 PM

Quote:
Originally Posted by ptycoupe View Post
I have a 2004 2.0L CVVT Tiburon... I've tried with several OBD-II tools (known good tools) and I cant manage to get a reading.

I currently own a ELMSCAN5... Tried with all sort of different softwares including SCAN XL.... no go.

Now I got a Equus 3130 scan tool.... Doesnt work. Tried it last night on a friends 1996 Neon and it worked flawlessly...

On mine... It tries to link... says... Detecting protocol.... ISO 9141.... Link 2000 and BAM... disconnected... Connection has been lost with the vehicle...

I've been reading about OBD-II port recalls, but the most detailed info I found was realted to 2002 V6 Euro Tibs with Inmobilizer....

BTW I've never been able to use the OBDII port....

Is it the ECU? Wiring harness? Port? Pins? Haunted car?

Cheers!


http://www.newtiburon.com/forums/sho...light=Obd+port


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
    Reply With Quote Quick reply to this message  


#3
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 05-18-2011 , 12:35 PM

Quote:
Originally Posted by Shark2005 View Post
read post!

the guy has a 2002 V6 with Inmobilizer. I went through the whole thing already.
    Reply With Quote Quick reply to this message  


#4
BramptonTib
NewTiburon.com God


BramptonTib is offline

BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Sex: Male
Posts: 1,352
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light

Old Re: OBD-II port useless 05-18-2011 , 07:07 PM

Read this thread
http://www.newtiburon.com/forums/sho...obd2+wont+scan

If you're thinking it's not your issue, instead of cutting and soldering the wires together, just short a wire between the 2 pins on the back of the connector as a way to test if this is your issue or not.
    Reply With Quote Quick reply to this message  


#5
reko
NewTiburon.com God


reko is offline

 
Join Date: Mar 2006
Location: Sheboygan
Sex: Male
Posts: 1,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
reko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of light

Old Re: OBD-II port useless 05-23-2011 , 08:10 PM

Just wondering if you have tried to have someplace like autozone or advance auto use one of their scanners on it?
    Reply With Quote Quick reply to this message  


#6
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 06-03-2011 , 04:51 PM

Quote:
Originally Posted by reko View Post
Just wondering if you have tried to have someplace like autozone or advance auto use one of their scanners on it?
They have... I even took it to the dealership... the car shows as "connected" but no data can be retrieved from the ECU and no live data, errors or anything.

btw.. there is not autozone or advance auto in Panama but I know the kind of places you mean.
    Reply With Quote Quick reply to this message  


#7
jawzgt
NewTiburon.com God


jawzgt is offline

jawzgt's Avatar
 
Join Date: Nov 2009
Location: Chicago Il
Sex: Male
Posts: 1,652
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
jawzgt has a spectacular aura aboutjawzgt has a spectacular aura about

Old Re: OBD-II port useless 06-03-2011 , 04:59 PM

well at least those jobs are secured.....those stores dont outsource lol
    Reply With Quote Quick reply to this message  


#8
reko
NewTiburon.com God


reko is offline

 
Join Date: Mar 2006
Location: Sheboygan
Sex: Male
Posts: 1,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
reko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of lightreko is a glorious beacon of light

Old Re: OBD-II port useless 06-05-2011 , 06:27 PM

Didn't notice the location, guess that makes a difference.

So it conncets, but no data can be read. I guess I would start with verifying continuity of the wires between the datalink connector and the ecm. maybe even do a wiggle test to see if its just a couple of loose wires.
    Reply With Quote Quick reply to this message  


#9
lukeman
PlastiDip Mod


lukeman is offline

lukeman's Avatar
 
Join Date: Dec 2009
Location: London Ontario Canada
Sex: Male
Posts: 2,968
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
lukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud oflukeman has much to be proud of

Old Re: OBD-II port useless 06-05-2011 , 06:32 PM

does your cigarette liter work?


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
Canada = Awesomeness eh!
Isnt it amazing how quickly everyone can turn against you
    Reply With Quote Quick reply to this message  


#10
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 07-01-2011 , 10:25 AM

Quote:
Originally Posted by reko View Post
Didn't notice the location, guess that makes a difference.

So it conncets, but no data can be read. I guess I would start with verifying continuity of the wires between the datalink connector and the ecm. maybe even do a wiggle test to see if its just a couple of loose wires.
Wiggle didnt have any effect. Probable next step will be the continuity of the cables =S

Quote:
Originally Posted by lukeman View Post
does your cigarette liter work?
Yes, it does work. All electrical things work
    Reply With Quote Quick reply to this message  


#11
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-18-2012 , 03:49 PM

is it a problem if I revive this thread? still having problems with the OBD port scanning or working at all.

EDIT: I soldered the wires at the back of the port as recommended in the links posted above and didnt help. I pulled the BCM to solder the cable 19 to 20 buuut... there was no cable in pin 20.

Last edited by ptycoupe; 09-18-2012 at 04:02 PM.
    Reply With Quote Quick reply to this message  


#12
breeechan
Dedication to Thai Cuisine


breeechan is offline

breeechan's Avatar
 
Join Date: Jul 2006
Location: Colorado
Sex: Male
Posts: 8,064
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
breeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud ofbreeechan has much to be proud of

Old Re: OBD-II port useless 09-18-2012 , 03:54 PM

Did you try wiring the ECU check engine output directly to the obd wire? My US (no immobilizer) 03 just stopped connecting recently, and I wired directly from the ECU to the OBD port as shown by Elric in the posts that others linked, and it works now.

Lightest DD tib? 2593 lbs and falling

Quote:
I wish I had 5 Guys inside of me right now...
Quote:
That is pretty much how I felt the first time I had Five Guys...
    Reply With Quote Quick reply to this message  


#13
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-18-2012 , 04:30 PM

well, I tried doing it from the BCM harness but... (((drums sound))) it do not seem to have the same connectors. I have no cable in pin # 20 (unless I'm viewing it wrong, it could be ) pin 20 is empty =S

Last edited by ptycoupe; 09-18-2012 at 04:32 PM.
    Reply With Quote Quick reply to this message  


#14
BramptonTib
NewTiburon.com God


BramptonTib is offline

BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Sex: Male
Posts: 1,352
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light

Old Re: OBD-II port useless 09-18-2012 , 08:12 PM

do you have an immobilizer? If you don't have the immobilizer, you won't have a wire in Pin 20.
    Reply With Quote Quick reply to this message  


#15
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-18-2012 , 11:45 PM

nope, or at least not the OEM one. I do have an aftermarket python alarm.
    Reply With Quote Quick reply to this message  


#16
The Slimer
NewTiburon.com Newbie


The Slimer is offline

 
Join Date: Nov 2011
Location: Vernon
Sex: Male
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
The Slimer is an unknown quantity at this point

Old Re: OBD-II port useless 09-20-2012 , 05:52 PM

I have never been able to get a reading on my OBD port in my 03 se
    Reply With Quote Quick reply to this message  


#17
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-21-2012 , 12:07 AM

UPDATE:
Talked to a guy from PR that has a workshop here and has a good reputation. Unfortunately he is not in the country but over the phone when I told him about the whole OBD2 problem he just asked... "does your CHECK ENGINE LIGHT comes on AT ALL? - answer = no, never ever, probably even if I rip the engine out of the car, it still won't" so he said... "alright, simple, you are not getting any power to that port... its either a missing ground or a missing b+".

So after soldering the pins 4 and 5 to fix the possible bad grounding issue, I'm just missing one of the steps from the threads above mentioned... run a wire directly from the ECU to pin 2 or crimp the k-line at the back of the BCM connector, which I'm still confuse since there is no pin nor cable on the 20th slot. wtf
    Reply With Quote Quick reply to this message  


#18
BramptonTib
NewTiburon.com God


BramptonTib is offline

BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Sex: Male
Posts: 1,352
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light

Old Re: OBD-II port useless 09-21-2012 , 06:44 AM

When you say the check engine light never comes on, are you saying when you turn the key to ON, and all the warning lights come on, that the check engine light doesn't come on?
    Reply With Quote Quick reply to this message  


#19
Elricdelyon
NewTiburon.com Professional


Elricdelyon is offline

Elricdelyon's Avatar
 
Join Date: Dec 2007
Location: France
Sex: Male
Posts: 948
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Elricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of light

Old Re: OBD-II port useless 09-21-2012 , 11:45 AM

I4 and v6 don't share the same harness. Have a look in your manual to find the k line pin of your ecu then wire it directly to the obd port.

2002 GT V6
Full race built block, Colt cams, MP90 SC, 90mmTB, RPW headers, custom catback w/ cutout, Hydra 2.6 EMS, J&S Safeguard, Phantom Grip, SPEC st5 clutch & Fidanza FW,
D2 Rally coilovers, Wilwood F&R BBK, Eibach sway / RRM strut / Ingalls smart arms, VPW endlinks & traction bars, custom bumper, shavings, CarPC...
Pending : Hydramist, Outlaw skirts, STuning bumper, M&S pods, Concepto diffuser, DB9 hood, new paint, 18' bronze wheels
    Reply With Quote Quick reply to this message  


#20
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-21-2012 , 02:45 PM

Quote:
When you say the check engine light never comes on, are you saying when you turn the key to ON, and all the warning lights come on, that the check engine light doesn't come on?
yeap, never turns on.

Quote:
I4 and v6 don't share the same harness. Have a look in your manual to find the k line pin of your ecu then wire it directly to the obd port.
do you know if all i4's will share the same harness..? I;ve downloaded the service manuals and some wiring diagrams but I dont know if they change from 03-04 to 05-06 or
    Reply With Quote Quick reply to this message  


#21
BramptonTib
NewTiburon.com God


BramptonTib is offline

BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Sex: Male
Posts: 1,352
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light

Old Re: OBD-II port useless 09-21-2012 , 03:02 PM

have you checked all 3 ECU fuses? There are 2 under the hood and 1 on the BCM.
    Reply With Quote Quick reply to this message  


#22
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-21-2012 , 03:40 PM

Quote:
have you checked all 3 ECU fuses? There are 2 under the hood and 1 on the BCM.
ECU fuses, not really. On the BCM itself? front side or backside? I took out the BCM a couple of days ago but wasn't really looking for a fuse hehe
    Reply With Quote Quick reply to this message  


#23
BramptonTib
NewTiburon.com God


BramptonTib is offline

BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Sex: Male
Posts: 1,352
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light

Old Re: OBD-II port useless 09-21-2012 , 03:53 PM

the fuse panel in the car (below the steering wheel), take the cover off an look at it, there is a fuse labelled ECU. Check that one. If it is fine, pop the hood, take the cover off the fuse box (driver's side, just north of the battery), look at the label on the cover, there are 2 fuses labelled ECU ones a 30 amp, the other a 10 amp. Check those.

I just think it's strange that your check engine light won't even come on when you turn the key to ON. Makes me think maybe part of the ECU is not getting power. I'm not sure why the ECU is feed by 3 different fuses, and obviously since the car runs, at least part of the ECU is getting power, but maybe one of those smaller fuses (the 10 amp ones) are blown.
    Reply With Quote Quick reply to this message  


#24
ptycoupe
NewTiburon.com God


ptycoupe is offline

ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Sex: Male
Posts: 1,462
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
ptycoupe will become famous soon enough

Old Re: OBD-II port useless 09-21-2012 , 05:09 PM

Quote:
Erica,

what is the EOS link to the survey?
Or were can I find the link?


Best regards,
Anne Hendriks
Will do that and post back. btw thank you BramptonTib for the input.

Hopefully getting this fix on my i4 may help some other people fix or diagnose a similar problem on theirs.
    Reply With Quote Quick reply to this message  


#25
slick91
NewTiburon.com God


slick91 is offline

slick91's Avatar
 
Join Date: Apr 2012
Location: New jersey
Sex: Male
Posts: 1,633
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
slick91

Old Re: OBD-II port useless 09-21-2012 , 05:10 PM

check the grounds a well. I had similar problem but in a volkswagen
    Reply With Quote Quick reply to this message  

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the New Tiburon Forum : Hyundai Tiburon Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:11 AM.



Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright © 2011 www.newtiburon.com. All rights reserved.
Designed by XG3