New Tiburon Forum : Hyundai Tiburon Forums - View Single Post - DIY: __*** BCM Turn Signal Fix ***__
View Single Post
post #7 of Old 04-28-2007, 08:33 PM
Tibzie
NewTiburon.com God
 
Tibzie's Avatar
 
Join Date: Nov 2006
Location: Calgary, AB
Posts: 1,273
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Tibzie
Re: DIY: BCM Turn Signal Fix

Quote:
Originally Posted by bms231 View Post
no problem. like my user title says, i am here to help. even if that means staying up super late to get things done. i am going to have this in PDF as well. i gotta run to work now though. it will be up later tonight.
When I first bought my car, they detailed everything for me and had it ready, when I arrive and they start it. the signal light was doing just as such. They had to order a new BCM and installed it (warranty). I went a few days w/ no signal lights cause I opted to still take the car that day.\

Anybody know what exactly causes this problem ?


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.


08' Civic SI Sedan | i-VTEC | 6 Speed | STS | CF Hood | TB Spacer | P2R Thermal Gaskets | Spoon Catback System | Megan Racing H Brace | M.R. F & R Tie bars | Eibach Lowering Prokit | Mugen Visors | Retrofit 5000k HID | 3000k Fogs/Highbeam |


To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
Tibzie is offline  
 
 
For the best viewing experience please update your browser to Google Chrome