New Tiburon Forum : Hyundai Tiburon Forums - View Single Post - NGM reflash issue, suggestions needed. Long.
View Single Post
post #7 of Old 07-19-2019, 09:00 PM Thread Starter
kellydood
NewTiburon.com God
 
kellydood's Avatar
 
Join Date: Jul 2004
Location: Minneapolis, Minnesota
Posts: 2,311
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 79 Post(s)
kellydood is just really nicekellydood is just really nicekellydood is just really nicekellydood is just really nice
(Thread Starter)
Hmm, to answer your questions, the IAT sensor is in the intake tube, and the TPS sweep has been verified. The 90mm NGM TB uses an OE TPS. I agree that the IAT sensor should be downstream of the SC, but I put it all together the way it was tuned to run. It actually runs pretty good in closed loop, and higher throttle positions are good although way too rich. Boost bypass valve is pinned 100% closed for now.

It's been probably a decade since I talked to John at J&S, so I wouldn't be able to answer your question. I plan to reach out to him again soon.

Which Haltech unit are you running? I probably will end up going that route. I want to set up boost control on this thing because I need launch control and boost by speed. The car's built for 400 whp and I have the pulleys for 23 psi. I will definitely crank it up there once I have the ability to tune it. There's some issues with belt slippage at that blower speed, but I know I can sort them out. I did run it up there one time, and fattened up the AFR by cranking up the FP. It was wild and just wanted to blow the tires off below about 50, so definitely looking to pull back the boost electronically at slower speeds.

Thanks for your offer of help. I may take you up on that sometime. I plan to start investigating standalone options and tuning this summer and fall. You have a 6 cylinder base map?
kellydood is offline  
 
 
For the best viewing experience please update your browser to Google Chrome