OBD connection failure and check engine light on - New Tiburon Forum : Hyundai Tiburon Forums
 
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 18 Old 01-16-2011, 08:31 PM Thread Starter
NewTiburon.com Newbie
 
Join Date: Jan 2011
Location: Jersey City
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
njohn is an unknown quantity at this point
(Thread Starter)
OBD connection failure and check engine light on

I tried to get the 2003 GT I purchased recently inspected in NJ and it failed due to OBD connection failure. I was afraid that the entire system was shot but the check engine light came on as a result of a leak in the flex pipe.

Does anyone have an idea of what this could be? The other posts on here don't have the additional info about a check engine light so I figured I'd throw this up here and see what people have to say.
njohn is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 01-16-2011, 08:38 PM
NewTiburon.com Novice
 
Chammy's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 251
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Chammy has a little shameless behaviour in the past
Re: OBD connection failure and check engine light on

i have an 03 as well they have an issue with no ground on the obd2 port so some scanners wll not read the car. if you need additional info on this PM me im in the middle of fixing mine right now i just tracked down the part number and am ordering it this week
Chammy is offline  
post #3 of 18 Old 01-16-2011, 08:45 PM
NewTiburon.com God
 
BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Posts: 1,351
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 39 Post(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light
Re: OBD connection failure and check engine light on

Ya there is a tsb on the obd2 port to add a missing ground on one of the pins which is needed for generic tools. There is also an issue with some 03's were the obd2 port doesn't work. I have this issue. Can't get any scanners to work on my car even after having the tsb done by the dealership. Here's a thread that talks more about that issue.
https://www.newtiburon.com/forums/sho...light=Obd+port
BramptonTib is offline  
post #4 of 18 Old 01-16-2011, 08:56 PM
NewTiburon.com Novice
 
Chammy's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 251
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Chammy has a little shameless behaviour in the past
Re: OBD connection failure and check engine light on

i hope it fixs mine i need to see my fuel trims
Chammy is offline  
post #5 of 18 Old 01-16-2011, 09:23 PM
NewTiburon.com Professional
 
Elricdelyon's Avatar
 
Join Date: Dec 2007
Location: France
Posts: 932
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Elricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of light
Re: OBD connection failure and check engine light on

Easy fix :

- First you have to bring back ground to the pin 5 of the OBD port. To do so, just solder a wire to the back of it, and solder the other side of the wire to the back of pin 4.

-If it's not enough, then you have to crimp a wire on the K line from the ECU (C133-1 / 3) directly to the OBD port (pin 2), so the signal will not be stopped by the BCM.



If you find it too hard to crimp a wire from the ECU harness, you can also crimp it from the BCM harness, it's much easier.




BCM IM pin 19




On the BCM IM plug, cut the wire going to pin 19, and crimp it on the wire going to pin 20, just as picture shows.

It worked for me and for many other users.

2002 GT V6
Full race built block, Colt cams, MP90 SC, 90mmTB, RPW headers, custom catback w/ cutout, Hydra 2.6 EMS, J&S Safeguard, Phantom Grip, SPEC st5 clutch & Fidanza FW,
D2 Rally coilovers, Wilwood F&R BBK, Eibach sway / RRM strut / Ingalls smart arms, VPW endlinks & traction bars, custom bumper, shavings, CarPC...
Pending : Hydramist, Outlaw skirts, STuning bumper, M&S pods, Concepto diffuser, DB9 hood, new paint, 18' bronze wheels

Last edited by Elricdelyon; 01-16-2011 at 09:26 PM.
Elricdelyon is offline  
post #6 of 18 Old 01-16-2011, 09:54 PM
NewTiburon.com God
 
BramptonTib's Avatar
 
Join Date: Aug 2005
Location: Brampton, Ontario
Posts: 1,351
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 39 Post(s)
BramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of lightBramptonTib is a glorious beacon of light
Re: OBD connection failure and check engine light on

Thanks Elricdelyon for that info. I had figured this would work as well by looking at the circuit diagrams. I think the problem lies with a bad relay in the BCM as the Kline goes in on Pin 20 and comes out on Pin 19, after going through a switch controlled by that relay. I can hear the relay clicking as my scan tool tries to negotiate with the ECU. Just haven't done the fix yet, as I don't have any CEL's I need to scan so figured no need to mess with it until the time comes.

Question to the OP, do you hear clicking when your scan tool tries to negotiate?
BramptonTib is offline  
post #7 of 18 Old 01-17-2011, 10:23 AM
NewTiburon.com Professional
 
Elricdelyon's Avatar
 
Join Date: Dec 2007
Location: France
Posts: 932
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Elricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of lightElricdelyon is a glorious beacon of light
Re: OBD connection failure and check engine light on

All Tiburon GT from 2002 with immobilizer have this problem, so i don't think it's a bad relay.

I hear the relays clicking too with my scan tool, it clicked with or without the mod, so don't worry with that.

2002 GT V6
Full race built block, Colt cams, MP90 SC, 90mmTB, RPW headers, custom catback w/ cutout, Hydra 2.6 EMS, J&S Safeguard, Phantom Grip, SPEC st5 clutch & Fidanza FW,
D2 Rally coilovers, Wilwood F&R BBK, Eibach sway / RRM strut / Ingalls smart arms, VPW endlinks & traction bars, custom bumper, shavings, CarPC...
Pending : Hydramist, Outlaw skirts, STuning bumper, M&S pods, Concepto diffuser, DB9 hood, new paint, 18' bronze wheels
Elricdelyon is offline  
post #8 of 18 Old 01-19-2011, 08:38 AM Thread Starter
NewTiburon.com Newbie
 
Join Date: Jan 2011
Location: Jersey City
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
njohn is an unknown quantity at this point
(Thread Starter)
Re: OBD connection failure and check engine light on

Hi guys turned out to be an airflow meter. The next day it rained and now the check engine light is back on and it runs hard when cold. Also the power mirrors aren't working. Was thinking it is a distributor/rotor and maybe guy who worked on it unplugged the mirrors.
njohn is offline  
post #9 of 18 Old 05-19-2011, 10:26 AM
NewTiburon.com God
 
ptycoupe's Avatar
 
Join Date: Jul 2007
Location: Panama City, Panama
Posts: 1,493
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 79 Post(s)
ptycoupe will become famous soon enough
Re: OBD connection failure and check engine light on

is this OBD2 fix applicable for 2.0L without inmo?

I cant get my ELMSCAN5 or my Equus 3130 to connect to the car...
ptycoupe is offline  
post #10 of 18 Old 12-14-2014, 12:36 AM
NewTiburon.com Newbie
 
Join Date: Jun 2013
Location: PERU
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
joshua007 is an unknown quantity at this point
Re: OBD connection failure and check engine light on

Hi Elric
sorryman , recently I see your post, I see that is quite old but I am very interested,
since I am trying to connect my ELM327 OBD port with my ECU in my old tiburon RD, Ecu Siemens MAP based,
Do you think this operation works for me? maybe ordering the OBD port pinout, as does the GK, I hope you can help me

Quote:
Originally Posted by Elricdelyon View Post
Easy fix :

- First you have to bring back ground to the pin 5 of the OBD port. To do so, just solder a wire to the back of it, and solder the other side of the wire to the back of pin 4.

-If it's not enough, then you have to crimp a wire on the K line from the ECU (C133-1 / 3) directly to the OBD port (pin 2), so the signal will not be stopped by the BCM.


If you find it too hard to crimp a wire from the ECU harness, you can also crimp it from the BCM harness, it's much easier.

[
On the BCM IM plug, cut the wire going to pin 19, and crimp it on the wire going to pin 20, just as picture shows.

It worked for me and for many other users.
joshua007 is offline  
post #11 of 18 Old 10-06-2018, 01:19 PM
NewTiburon.com Newbie
 
Join Date: Oct 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bob weber is an unknown quantity at this point
Re: OBD connection failure and check engine light on

I am working on my son 03 tiburon gt. Obd2 not working. Ground is good but pin for hot wire shows grounded any ideas. New to this site
Bob weber is offline  
post #12 of 18 Old 01-19-2019, 12:32 PM
NewTiburon.com Newbie
 
Join Date: Jul 2017
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
kgmoikra is an unknown quantity at this point
Re: OBD connection failure and check engine light on

Which obd2 scanner did you buy for this? All scanners don't support tiburon gt. I am thinking to buy Autel AL619 scanner https://bestobd2scanners.com/autel/al619-review/. Do you have any experience with this Autolink tool?

Last edited by kgmoikra; 05-05-2019 at 07:11 AM.
kgmoikra is offline  
post #13 of 18 Old 05-23-2019, 11:01 AM
NewTiburon.com Newbie
 
Join Date: May 2019
Location: Seville, Spain
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ignabetiss@gmail.com is an unknown quantity at this point
Garage
Re: OBD connection failure and check engine light on

Hello,

It seems that the photos were deleted. Could they upload them again ?. Very thankful.
post #14 of 18 Old 05-23-2019, 03:53 PM
Still the same me...
 
Charlie-III's Avatar
 
Join Date: Jan 2013
Location: USA, North NJ 07456
Posts: 8,538
Mentioned: 251 Post(s)
Tagged: 1 Thread(s)
Quoted: 2232 Post(s)
Charlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud of
Re: OBD connection failure and check engine light on

Quote:
Originally Posted by [email protected] View Post
Hello,

It seems that the photos were deleted. Could they upload them again ?. Very thankful.
If you're getting an error from PhotoBucket.....do an online search for your browser and PhotoBucket....there are many free patches.

Otherwise.....what year, model, engine, trans, mods and issues do you have?

Wifes car: 2004 Tib GT, 2.7L, 5MT, 193K miles, medium blue, basically stock.
My car: 1998 Legacy GT wagon, 2.5L, 5MT, 176K miles, "Quicksilver", not stock and not slow...
To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.


"life is lived, one corner at a time".
To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.


Best NT.com '13 New-Comer, NT.com '13 Technical Advise & Info (runner-up), NT.com '13 Non-Tib (3rd) .
Charlie-III is offline  
post #15 of 18 Old 05-23-2019, 04:05 PM
NewTiburon.com Newbie
 
Join Date: May 2019
Location: Seville, Spain
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ignabetiss@gmail.com is an unknown quantity at this point
Garage
Re: OBD connection failure and check engine light on

Quote:
Originally Posted by Charlie-III View Post
If you're getting an error from PhotoBucket.....do an online search for your browser and PhotoBucket....there are many free patches.

Otherwise.....what year, model, engine, trans, mods and issues do you have?
Sorry for the manners. Between desperate looking for a solution. As soon as I can I will fill in all the perfl and my presentation.

Since February I have a hyundai Coupe 2.7 V6 2002 with exhaust and modified intake.

Yesterday, traveling on the road, the check engine witness came on and I can not connect via OBD II.

I went to the official dealer and they charge me $ 76 just for diagnosing.

If you could help me I would appreciate it very much.

As for the photos of the post, I have installed a patch but I still do not see them. Can you see them?
post #16 of 18 Old 05-23-2019, 04:08 PM
Still the same me...
 
Charlie-III's Avatar
 
Join Date: Jan 2013
Location: USA, North NJ 07456
Posts: 8,538
Mentioned: 251 Post(s)
Tagged: 1 Thread(s)
Quoted: 2232 Post(s)
Charlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud ofCharlie-III has much to be proud of
Re: OBD connection failure and check engine light on

What code came up when dealer looked at it? Not a description, we want the code since the description can be a few things, code may narrow it down.....

Where are you located? In the US, your model year is a "RD", most here are "GK" although rather similar mechanical stuff.....

I am running an iPad, thus sorta a PITA to fix things online.....

Wifes car: 2004 Tib GT, 2.7L, 5MT, 193K miles, medium blue, basically stock.
My car: 1998 Legacy GT wagon, 2.5L, 5MT, 176K miles, "Quicksilver", not stock and not slow...
To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.


"life is lived, one corner at a time".
To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.


Best NT.com '13 New-Comer, NT.com '13 Technical Advise & Info (runner-up), NT.com '13 Non-Tib (3rd) .
Charlie-III is offline  
post #17 of 18 Old 05-23-2019, 04:19 PM
NewTiburon.com Newbie
 
Join Date: May 2019
Location: Seville, Spain
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ignabetiss@gmail.com is an unknown quantity at this point
Garage
Re: OBD connection failure and check engine light on

Quote:
Originally Posted by Charlie-III View Post
What code came up when dealer looked at it? Not a description, we want the code since the description can be a few things, code may narrow it down.....

Where are you located? In the US, your model year is a "RD", most here are "GK" although rather similar mechanical stuff.....

I am running an iPad, thus sorta a PITA to fix things online.....
In the distributor did not get to read it because of the high price I refused. I buy an ELM327 device and I'm trying to read the code but torque says it has no communication with the ECU. My vehicle is GK European model, I'm from Spain. Reading this post I think I am missing the negative connection on pin 5 of the OBD and the signal from the ECU on pin 2. But I do not know how to do the installation without seeing photos, I do not have much knowledge ...
post #18 of 18 Old 06-07-2019, 11:29 AM
NewTiburon.com Newbie
 
Join Date: Jun 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AliceSean is an unknown quantity at this point
Re: OBD connection failure and check engine light on

Nice post. . .
AliceSean is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the New Tiburon Forum : Hyundai Tiburon Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome