Hyundai Tiburon Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2003 supercharged tiburon with cold air intake, 18 inch wheels, 6 speed manual transmission and a stage 1 mafterburner wired in my glovebox. over the past few years the car has had issues and ive been in school and unable to afford to fix the problems. I recently dumped the money into it and had a dealership fix everything and the car is in tip top shape, except that one of my cylinders is running at -50%. The dealerships Service manager told me that it was most likely the tune on the car, and they were unable to do anything else for me there. Ive looked into a few tune shops around my area and no one works with mafterburners. Any advice?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I have a 2003 supercharged tiburon with cold air intake, 18 inch wheels, 6 speed manual transmission and a stage 1 mafterburner wired in my glovebox. over the past few years the car has had issues and ive been in school and unable to afford to fix the problems. I recently dumped the money into it and had a dealership fix everything and the car is in tip top shape, except that one of my cylinders is running at -50%. The dealerships Service manager told me that it was most likely the tune on the car, and they were unable to do anything else for me there. Ive looked into a few tune shops around my area and no one works with mafterburners. Any advice?
the car idles beautifully and runs up to around 2k rpms and chokes itself to a stall, theres no engine light. i do have an airbag light but i doubt that has anything to do with it.
 

·
Registered
Joined
·
2,656 Posts
"one of my cylinders is running -50%", this makes no sense, where are you getting this number from?
 

·
Registered
Joined
·
722 Posts
will a power chip support a stage 2 s/c setup?
 

·
Registered
Joined
·
722 Posts
you can ditch your piggy back and hit up power chip. I've been running their ECM for about 6 years or so.
btw 50% sounds like its getting half the amount of fuel compared to the others.
 

·
Registered
Joined
·
2,038 Posts
btw 50% sounds like its getting half the amount of fuel compared to the others.
Not that I have much of a clue what is wrong with the car but if the car is not getting the proper fuel I would say clogged injector or something to that nature. I doubt that is the problem though cause the dealership would have fixed that issue.
 

·
Registered
Joined
·
2,656 Posts
btw 50% sounds like its getting half the amount of fuel compared to the others.
First off, the ecu cannot add or subtract that much, it is maxed out at 31.3%, second whatever percentage it's off, +/-, is for each 'bank' of cylinders, not individual cylinders.
 

·
Registered
Joined
·
722 Posts
Try swapping injectors; see if the problems moves over to the other cylinder? My basic troubleshooting skills ha ha.
 
1 - 10 of 10 Posts
Top