Hyundai Tiburon Forums banner

1 - 4 of 4 Posts

·
Premium Member
2003 Tiburon GT V6
Joined
·
4 Posts
Discussion Starter #1
Threw timing belt. Rebuilt from ground up. EVERYTHING NEW. No more cats. No low end power. P0303,305, random misfire. Maybe a bad New coil. Reset timing belt one notch. Would appreciate any ideas\help. First day on forum.
 

·
Administrator
Joined
·
8,820 Posts
Double check plug wires. Which wire goes into which coil tower makes no difference.....which coil a plug wire goes into makes a difference.
I am guessing you swapped 2 wires.....thus the 2 misfires and random misfire codes....
This would be firewall side, center and trans end plugs are likely swapped.
 

·
Premium Member
2003 Tiburon GT V6
Joined
·
4 Posts
Discussion Starter #3
Double check plug wires. Which wire goes into which coil tower makes no difference.....which coil a plug wire goes into makes a difference.
I am guessing you swapped 2 wires.....thus the 2 misfires and random misfire codes....
This would be firewall side, center and trans end plugs are likely swapped.
Thanks for the information. I'll swap the two later today and see what happens. I'll let you know.
 

·
Premium Member
2003 Tiburon GT V6
Joined
·
4 Posts
Discussion Starter #4
Swapped those wires. Immediately started to backfire. Warmed up and drove 100 yrds. Check engine light came on went back to garage. Engine light went off. I put the plug wires on per Tiburon manual. Firewall back on coil 6,3,5,2,4,1. Followed all plug wires from 1,3,5 (firewall) 2,4,6 (radiator). Drove again. Same error code 3,5 and multiple. ?????
 
1 - 4 of 4 Posts
Top