Hyundai Tiburon Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
314 Posts
Discussion Starter #1
I have an 04 GT V6, this morning I went out to start it all lights came on door buzzer worked but no clicking no sound when trying to start.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #3
was out all day saturday in the tib no issues. Sat sunday, then not start this morning.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #4
Started the car after I got home from work. It started but now i have oil under the car and covering the engine.
 

·
Super Moderator
Joined
·
8,607 Posts
First off....AT or MT?
If AT, when it won't crank, try it in neutral.
If MT, could be clutch switch which you can jumper to bypass as a test.

Oil leak......oil fill cap loose? Maybe leaking oil filter? I had a filter rust through the end of the filter. Maybe even a failed oil pressure switch.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #6
it is the auto tranny
 

·
Registered
Joined
·
473 Posts
Started the car after I got home from work. It started but now i have oil under the car and covering the engine.
So, how did it start?

Also add info such as miles, recent maintenance. Use some engine de-greaser and check where the oil leak is from.
Check oil pan gasket along with other things suggested above.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #8
It started normal
 

·
Registered
Joined
·
314 Posts
Discussion Starter #9
50,000 miles on engine - oil change every 5,000 miles
 

·
Registered
Joined
·
314 Posts
Discussion Starter #10
Could it be the oil pressure check relief valve going bad?
 
1 - 10 of 10 Posts
Top