Hyundai Tiburon Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
So recently my AC has been acting up a bit. I have the electronically controlled dash and over the last month or so I've had to put my fan speed on max in order to have any air come from my vents. Yesterday it finally seemed to stop working all together, although all the buttons on the dash still work and I do notice a performance change when the AC is "on."

I don't know too much if anything about the AC system in cars but I'm hoping this could be something I could do with a little help. Am I right in thinking it has something to do with the blower motor itself?
 

·
Administrator
Joined
·
8,873 Posts
There a couple of likely suspects.

One is the blower resistor can fail, the other is the fan speed control switch gets too hot & fails.

The first one is covered in a couple of threads (now you have an idea on what to look for), the fan switch itself is covered by a DIY.

I'll be honest and say I'm not sure the 2nd one is what you have though.

NOTE: the blower failing is NOT likely, it's the speed control circuit more than likely.
 

·
Administrator
Joined
·
8,873 Posts
This is normal.
Yessssss......... this means the AC clutch is engaging (and the ECU is changing the idle speed), but NOT really helpful to fix the issue.

Thanks for playing though.
 

·
Registered
Joined
·
1,295 Posts
What year Tib?
 

·
Registered
Joined
·
1,905 Posts

·
Registered
Joined
·
856 Posts
Yessssss......... this means the AC clutch is engaging (and the ECU is changing the idle speed), but NOT really helpful to fix the issue.

Thanks for playing though.
It helped in that he was unsure if it was normal to lose a bit of performance when the A/C is on, and I confirmed that for him.

Thank you though, for taking the time to point it out. It contributed a lot to this thread.
 

·
Administrator
Joined
·
8,873 Posts
It helped in that he was unsure if it was normal to lose a bit of performance when the A/C is on, and I confirmed that for him.

Thank you though, for taking the time to point it out. It contributed a lot to this thread.
Touche......
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Thanks for the help, I'll hopefully try and further diagnose the problem today. The blower turned on randomly last night and seemed to work fine this morning, but I still want to see what's causing my blower to only turn on when the fan speed is on full blast.
 
1 - 10 of 10 Posts
Top