Hyundai Tiburon Forums banner
1 - 5 of 5 Posts

· Registered
2003 Hyundai Tiburon GT
Joined
·
2 Posts
Discussion Starter · #1 ·
Vehicle was my Father In Laws. He purchase brand new. Has 41k original miles. I got it from him in June of this year. I started getting loud crackling, it would go away. A few months ago got the crackle and now the Stereo powers on but there is no sound at all.

All fuses that I can locate are all fine.

Very new to this and looking to get it fixed. Looking for suggestions.

Thanks in advance.
 

· Registered
Joined
·
879 Posts
Check your sunroof rear drains, the early models had a problem with the rear drain tubes falling off & draining straight onto the headliner, then running onto the amplifier. Symptoms included popping/buzzing to complete failure when it rained.
 

· Administrator
Joined
·
9,550 Posts
Does everything else electrical still work? Things like dash lights, interior lights, etc?
If those are out, check the "dealer fuse" under the yellow cover towards the upper left of the BCM/fuse box under the dash towards the left.
And yes, check your roof drains. There are 4, one in each corner.
 

· Administrator
Joined
·
9,550 Posts
I dislike "looking" at fuses, metering (either continuity or voltage) is best. I have had too many repairs/fixes to other people's cars when a fuse looked good but was actually cleared/blown.

To check drains.....open sunroof, look for the hole in each corner. Using a cup, pour water in each corner and watch for water under the car. Front drains come out about the door hinges line. Rear drains are behind the rear of the door opening.
 
1 - 5 of 5 Posts
Top