Hyundai Tiburon Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all. New here. Fustrated and don't have time to read every thread on issue. So figured I'd just ask.
I just recently bought my second Tib. The first was a 2004 - 4 speed auto. Now I have a a 6 speed manual of the same year.
Thr problem I'm having is that it has now stuck in reverse. The shifter will move, but will not engage or lock into any other gears. I replaced the Clutch slave and Clutch Master Cylinder because the guy I bought it from and thought they were a problem to be had eventually. He had had the clutch replaced within the last year. I replaced the starter just recently myself.
So back to the 'stuck in reverse' issue.

I checked the cables that attach to transmission from the shifter. I HAVE NO IDEA WHAT THAT ASSEMBLY THE CABLES ATTACH TO IS CALLED. It's the component that allows shifting up/ down and forward/ back the cables attach to on tranny.
Well bushings are BAD as well as billows that need replaced. Can (I imagine this is my issue) this cause the tranny to stick in reverse? If so and even if not, what is that stupid assembly part called? :unsure::unsure::unsure:
 

·
Registered
Joined
·
2,337 Posts
Not sure what the assembly is called, and if your bushings are bad I'd start there. While you're at it go ahead and replace them with some more solid ones than the crappy stock rubber. Ebay has some nice ones I recently used on my 07.

Basically the cables (with bushings) allow the assembly on top of the tranny to move and engage different gears. You could unhook both cables and see if you can move the assembly by hand into other gears. If you can't, you have a bigger problem than just the cables/bushings.
 
1 - 2 of 2 Posts
Top