Hyundai Tiburon Forums banner
381 - 400 of 402 Posts

·
Administrator
Joined
·
9,108 Posts
Resurrecting an old thread but my wife has just encountered this problem on her '04 Tiburon.

Did anyone manage to save photos ro any other info on this. Everywhere that has photos they have disappeared and any link to PDF's on this search are also no good.

Any help appreciated.
It is an old thread. If you get a Photobucket message, do an online search for your browser (Google, Chrome, etc.) and Photobucket for an addon that normally makes pictures visible again.
:nerd2::wink2:
 

·
Registered
Joined
·
4 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
 

·
Administrator
Joined
·
9,108 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
Wen you say, "doesn't work", do they not come on, they don't flash, what?
 

·
Registered
Joined
·
4 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
Wen you say, "doesn't work", do they not come on, they don't flash, what?
Yeah for some reason the left turn signal doesn't flash. Not even with the hazards on. Only the right turn signal works. I've checked if there is power going to the left sigbal bulb and their is it just doesn't flash. I've already replaced the turn signal switch and still nothing.
 

·
Administrator
Joined
·
9,108 Posts
Yeah for some reason the left turn signal doesn't flash. Not even with the hazards on. Only the right turn signal works. I've checked if there is power going to the left sigbal bulb and their is it just doesn't flash. I've already replaced the turn signal switch and still nothing.
As staff, I will start off with.......fill in a location. State or Provence is fine in North America.

Is it hard to fix? Not really, but, most PC boards since sometime in the '90's are lead free solder, thus harder to deal with.
If you are decent at soldering, you can fix it.
Otherwise find a shop that does trucker radios, ham radio, etc. Ask them if you supply relays and a board, will they do the work. You need to pull the BCM, pull the board out, may even have parts.
Relay PN's are listed, rather cheap from Digikey and others.
 

·
Registered
Joined
·
1 Posts
Make the long story short my DL turn signal just stays on even if I turn off my car. It stays on. So i did some research of my own and found it to be BCM to make sure i was correct i took it to the shop i normally go and they validated this for me that it is, in fact, the BCM. From there i ordered a BCM from eBay that would fit in my car... (i did not check to see if the part # matched. When i ordered this i was unsure how to find this/didnt know i need this ) i have a 04 GT Tib btw.

So now I keep trying to get this installed by a shop but they all want to re-diagnose the issue as they dont think its my BCM which means another 100 out the door. The shop I took it too that said it was my BCM said that they could not install this as they could not program it due to not having the tool to program this.

but if I don't use a key fob and this came out of a tib should I be fine just to have this installed? and do i need to have anything solidered. the photos on the first post wont show up for me. I would install this myself if it didnt need to be program which idk if it does or not
 

·
Administrator
Joined
·
9,108 Posts
Make the long story short my DL turn signal just stays on even if I turn off my car. It stays on. So i did some research of my own and found it to be BCM to make sure i was correct i took it to the shop i normally go and they validated this for me that it is, in fact, the BCM. From there i ordered a BCM from eBay that would fit in my car... (i did not check to see if the part # matched. When i ordered this i was unsure how to find this/didnt know i need this ) i have a 04 GT Tib btw.

So now I keep trying to get this installed by a shop but they all want to re-diagnose the issue as they dont think its my BCM which means another 100 out the door. The shop I took it too that said it was my BCM said that they could not install this as they could not program it due to not having the tool to program this.

but if I don't use a key fob and this came out of a tib should I be fine just to have this installed? and do i need to have anything solidered. the photos on the first post wont show up for me. I would install this myself if it didnt need to be program which idk if it does or not
Just install it, key fob is in the ECU.
 

·
Premium Member
Joined
·
5,306 Posts
Discussion Starter · #389 · (Edited)

·
Administrator
Joined
·
9,108 Posts
if left side signal lights work and the right side doesn't would this fix that to? also when push the hazard light the left side works but the right side doesnt
Assuming bulbs on right side are good, then yes, the BCM fix should work.
 

·
Registered
Joined
·
5 Posts
Sorry to resurrect. I've an 07 and didn't see anything in the back pages but the relay to replace is actually two small ones. So im assuming I cant use the part I ordered in the first post. Any one have any ideas?
 

·
Registered
Joined
·
1 Posts
Here is a link to my photo album with the BCM pictures for those who still might like to see them.



Edit: Also, photos have been added back to 1st post.
Is it possible to re-up this album or post pictures somewhere else? Link shows "album doesn't exist" and pictures in the 1st post are blurred. I just registered, looking for solution to my problem with turn signals. Help please :cry:
 

·
Registered
Joined
·
1 Posts
Hi, I know 2020 is pretty late in the game but my Wifes '04 V6 Tib has recently had this problem.
I removed the BCM, took it to a PC/TV repair guy along with the relay from mouser but have found different problems since refitting everything.
So, the first startup was perfect, everything worked as per normal.
The second start cranked but wouldn't fire, indicators flashing like an immobiliser issue but weirdly so were the front fog lights.
Disconnect the battery, check everything is plugged in and such, reconnect the battery and it starts fine, everything works.
Turning it off and trying to start again it plays up in the same fashion as above.

Do I need the repaired BCM re-programmed after being unplugged for a week or so?
Is my BCM just totaled and needs replacing?

About replacing the BCM, the P/N is 95410-2C082, in all searches I have done for a replacement this says it is for a 4cyl but my Wifes car is 100% as it left the factory as a V6 auto.
Are some BCM part numbers interchangeable, signaling this car has had the problem before. Seems to me most people cars on here have run into problems with-in 3 to 5 years. We got her car in 2014 with 180,000ks on the clock, now 16 years old with over 220,000ks (135,000m) so it stands to reason it would have gone before now.

Any help would be greatly appreciated.

Oh, I am from Australia :)
 

·
Registered
2004 Hyundai Tiburon
Joined
·
117 Posts
Will the part EP2-3N1S work for this? I think I ordered the wrong ones....Thanks.
 

·
Registered
Joined
·
56 Posts
I had my left signal lights get stuck in ON state. I followed this great DIY and the problem is solved. Thank you!
 

·
Registered
Joined
·
2 Posts
Well I bought an 2007 Siii and after driving it away 50 miles down the road the right side indicator came on, and stayed on!

I did a bit of googling, found this wonderful forum and got some new relays ordered.

The relays arrived, I started to remove the BCM - noticing in the process that it had been removed before, the metal knee protection was missing, as was the screw at the top of the BCM, plus the BCM had clearly been opened already. I also noticed that a bunch of the wires going to the BCM had been cut and rejoined - this car has obviously had some electrical issues in the past!

Anyway, I got the BCM removed and opened up - all of the relays inside had been butchered, the cases had been cut off them!

Still, I'm thinking, no big deal I'll just replace them all (I ordered enough relays to do the lot).

All the relays are now replaced with new ones and the BCM is back in the car... The right side indicator is still flashing away :(

I looked at the wiring diagram for the car and disconnected the wires from the switch - just to check the switch wasn't at fault.

So now I'm stuck. Do I need to be looking for a new BCM?
 

·
Premium Member
2006 Hyundai Tiburon SE
Joined
·
1,093 Posts
Well I bought an 2007 Siii and after driving it away 50 miles down the road the right side indicator came on, and stayed on!

I did a bit of googling, found this wonderful forum and got some new relays ordered.

The relays arrived, I started to remove the BCM - noticing in the process that it had been removed before, the metal knee protection was missing, as was the screw at the top of the BCM, plus the BCM had clearly been opened already. I also noticed that a bunch of the wires going to the BCM had been cut and rejoined - this car has obviously had some electrical issues in the past!

Anyway, I got the BCM removed and opened up - all of the relays inside had been butchered, the cases had been cut off them!

Still, I'm thinking, no big deal I'll just replace them all (I ordered enough relays to do the lot).

All the relays are now replaced with new ones and the BCM is back in the car... The right side indicator is still flashing away :(

I looked at the wiring diagram for the car and disconnected the wires from the switch - just to check the switch wasn't at fault.

So now I'm stuck. Do I need to be looking for a new BCM?
If the relays on the BCM main board were butchered it's likely that the board was also butchered in an attempt to repair/replace. I know for sure that while removing the relays it's rather difficult without a proper heat gun desolder/resolder station with precision temperature controls. For example I use an Aoyue 968+ station for electrical repairs.

Just know that there is an IMMOBILIZER on nearly all Tiburons outside of the US. This means if your car has an immobilizer, your BCM needs to match the ignition key module or your car will not start. Additionally the 2007-2008 immobilizers are a little different and somehow perform a VIN check against the ECM over the CANBUS. You can work around the VIN check by using an older ECM from 2004-2006 so that's an easy work around if you can find a matching BCM and ignition key module. Otherwise a sure fire way to get around the immobilizer issue is to source a US spec BCM and ECM so you can delete the immobilizer.
 
381 - 400 of 402 Posts
Top