Hyundai Tiburon Forums banner

381 - 394 of 394 Posts

·
Super Moderator
Joined
·
8,590 Posts
Resurrecting an old thread but my wife has just encountered this problem on her '04 Tiburon.

Did anyone manage to save photos ro any other info on this. Everywhere that has photos they have disappeared and any link to PDF's on this search are also no good.

Any help appreciated.
It is an old thread. If you get a Photobucket message, do an online search for your browser (Google, Chrome, etc.) and Photobucket for an addon that normally makes pictures visible again.
:nerd2::wink2:
 

·
Registered
Joined
·
4 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
 

·
Super Moderator
Joined
·
8,590 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
Wen you say, "doesn't work", do they not come on, they don't flash, what?
 

·
Registered
Joined
·
4 Posts
Alright guys so I have a 2003 that for some reason the left turn signal doesn't work. Their is power going to it and the right turn signal works but for some reason the left doesn't. Any ideas? How hard is it to repair the turn signal relay?
Wen you say, "doesn't work", do they not come on, they don't flash, what?
Yeah for some reason the left turn signal doesn't flash. Not even with the hazards on. Only the right turn signal works. I've checked if there is power going to the left sigbal bulb and their is it just doesn't flash. I've already replaced the turn signal switch and still nothing.
 

·
Super Moderator
Joined
·
8,590 Posts
Yeah for some reason the left turn signal doesn't flash. Not even with the hazards on. Only the right turn signal works. I've checked if there is power going to the left sigbal bulb and their is it just doesn't flash. I've already replaced the turn signal switch and still nothing.
As staff, I will start off with.......fill in a location. State or Provence is fine in North America.

Is it hard to fix? Not really, but, most PC boards since sometime in the '90's are lead free solder, thus harder to deal with.
If you are decent at soldering, you can fix it.
Otherwise find a shop that does trucker radios, ham radio, etc. Ask them if you supply relays and a board, will they do the work. You need to pull the BCM, pull the board out, may even have parts.
Relay PN's are listed, rather cheap from Digikey and others.
 

·
Registered
Joined
·
1 Posts
Make the long story short my DL turn signal just stays on even if I turn off my car. It stays on. So i did some research of my own and found it to be BCM to make sure i was correct i took it to the shop i normally go and they validated this for me that it is, in fact, the BCM. From there i ordered a BCM from eBay that would fit in my car... (i did not check to see if the part # matched. When i ordered this i was unsure how to find this/didnt know i need this ) i have a 04 GT Tib btw.

So now I keep trying to get this installed by a shop but they all want to re-diagnose the issue as they dont think its my BCM which means another 100 out the door. The shop I took it too that said it was my BCM said that they could not install this as they could not program it due to not having the tool to program this.

but if I don't use a key fob and this came out of a tib should I be fine just to have this installed? and do i need to have anything solidered. the photos on the first post wont show up for me. I would install this myself if it didnt need to be program which idk if it does or not
 

·
Super Moderator
Joined
·
8,590 Posts
Make the long story short my DL turn signal just stays on even if I turn off my car. It stays on. So i did some research of my own and found it to be BCM to make sure i was correct i took it to the shop i normally go and they validated this for me that it is, in fact, the BCM. From there i ordered a BCM from eBay that would fit in my car... (i did not check to see if the part # matched. When i ordered this i was unsure how to find this/didnt know i need this ) i have a 04 GT Tib btw.

So now I keep trying to get this installed by a shop but they all want to re-diagnose the issue as they dont think its my BCM which means another 100 out the door. The shop I took it too that said it was my BCM said that they could not install this as they could not program it due to not having the tool to program this.

but if I don't use a key fob and this came out of a tib should I be fine just to have this installed? and do i need to have anything solidered. the photos on the first post wont show up for me. I would install this myself if it didnt need to be program which idk if it does or not
Just install it, key fob is in the ECU.
 

·
Administrator
Joined
·
5,302 Posts
Discussion Starter #389 (Edited)

·
Registered
Joined
·
1 Posts
if left side signal lights work and the right side doesn't would this fix that to? also when push the hazard light the left side works but the right side doesnt
 

·
Super Moderator
Joined
·
8,590 Posts
if left side signal lights work and the right side doesn't would this fix that to? also when push the hazard light the left side works but the right side doesnt
Assuming bulbs on right side are good, then yes, the BCM fix should work.
 

·
Registered
Joined
·
2 Posts
Sorry to resurrect. I've an 07 and didn't see anything in the back pages but the relay to replace is actually two small ones. So im assuming I cant use the part I ordered in the first post. Any one have any ideas?
 

·
Registered
Joined
·
1 Posts
Great Post! Thanks for this! Your directions were flawless. I'm very thankful you put this thread out for the world to see. Thank you again!
 
381 - 394 of 394 Posts
Top