Hyundai Tiburon Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4,295 Posts
Discussion Starter #1
anyone know what it might be?

It's reading 10.0 throughout WOT at every RPM.. and i've lost alot of whp because of it.
I know the problem is electrical, but what could cause it?

MAF?
Apex?
any other sensor?
 

·
Registered
Joined
·
2,172 Posts
check apexi numbers, maybe its been messed with, possibly the MAF going into limp mode to the 10's, not really sure, does it affect drivability.....
Chase
Ill try to help.
Not sure what would cause that
 

·
Registered
Joined
·
2,218 Posts
Zaion said:
anyone know what it might be?

It's reading 10.0 throughout WOT at every RPM.. and i've lost alot of whp because of it.
I know the problem is electrical, but what could cause it?

MAF?
Apex?
any other sensor?
Hello,

Sounds like the car is in limp mode. Is the CEL on?

Thanks T.C.
 

·
Registered
Joined
·
2,172 Posts
he jumps to ask a question and then jumps off LOL
Chase
 

·
Registered
Joined
·
2,172 Posts
like a limp dick, its hard to beat LOL
Chase
 

·
Registered
Joined
·
4,295 Posts
Discussion Starter #7
It doesn't throw a cel

And i've gone down from 310whp to about 230whp :(

If it is limp mode, any idea how to solve it? I bet it could be caused by lots of things, and if so, I'm gona have alot of headaches...
 

·
Registered
Joined
·
2,218 Posts
Zaion said:
It doesn't throw a cel

And i've gone down from 310whp to about 230whp :(

If it is limp mode, any idea how to solve it? I bet it could be caused by lots of things, and if so, I'm gona have alot of headaches...
Hello,

I would have to go through your whole combination and see what is out of wack. Or, Ruben can take a look at it, but he is in Singapore right now.

Thanks T.C.
 

·
Registered
Joined
·
4,295 Posts
Discussion Starter #9 (Edited)
Nextgen03gt said:
Hello,

I would have to go through your whole combination and see what is out of wack. Or, Ruben can take a look at it, but he is in Singapore right now.

Thanks T.C.
I've talked to Ruben, but we didn't know exactly what was happening. He told me about the trip, so when he gets back i'll call him.

EDIT: read up on limp mode... but my car hasnt thrown a CEL, and its been over a week
 

·
Registered
Joined
·
4,295 Posts
Discussion Starter #10
bump?

123456
 
1 - 10 of 10 Posts
Top