Hyundai Tiburon Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,847 Posts
Discussion Starter · #1 ·
Well with my header leak now fixed (header wasnt properly mounted from install of the obx due to them not machining the holes in the correct spacing) I'm now free of exhaust leaks. However, from the exhaust leak I was having, when I floored it, my car would dip down on the a/f ratio, and the car felt like it wasnt trying to pull at all (timing being pulled back)

Well now, since the fix, my a/f ratio shot up to 13.5-12.5 as the rpms climb. Cruising or idle is exactly at 14.5-15.0. Would a leak seriously cause that many problems with the a/f ratio and timing being pulled? I guess that would make sense with cold air being sucked in, but im curious to what you people think. Also, how does my WOT a/f ratio sound? Its very stable on those numbers too, and it pulls hard. No pinging at all either.
 

·
Registered
Joined
·
1,614 Posts
Well with my header leak now fixed (header wasnt properly mounted from install of the obx due to them not machining the holes in the correct spacing) I'm now free of exhaust leaks. However, from the exhaust leak I was having, when I floored it, my car would dip down on the a/f ratio, and the car felt like it wasnt trying to pull at all (timing being pulled back)

Well now, since the fix, my a/f ratio shot up to 13.5-12.5 as the rpms climb. Cruising or idle is exactly at 14.5-15.0. Would a leak seriously cause that many problems with the a/f ratio and timing being pulled? I guess that would make sense with cold air being sucked in, but im curious to what you people think. Also, how does my WOT a/f ratio sound? Its very stable on those numbers too, and it pulls hard. No pinging at all either.
if it's 12.5 on wot- it sounds a bit too lean,
at idle- sounds superb
 

·
Registered
Joined
·
1,847 Posts
Discussion Starter · #3 ·
Now my car is stuck at 14.0 even at WOT. Im completely stumped, I even replaced my 02 sensor. Everytime i richen it, it doesnt do anything, and when i decrease fuel the car stalls. I need idea's please!
 

·
Registered
Joined
·
1,847 Posts
Discussion Starter · #4 ·
Could this be a sign that my fuel pump is going? I see NO code at all bring triggered, and even when i disable my primary 02 my car still wont go rich beyond 14.0, but i can lean it out and stall it. Fuel pump?
 

·
Registered
Joined
·
456 Posts
well im sorry i dont have any input on your fuel pump problem but I did just recently have an exhaust leak fixed right before my turbo and it re arranged my AFR by a good bit. Im having to retune the car as i drive now.
 

·
Registered
Joined
·
1,614 Posts
i'd say no, it would lean out in any case with growing revs and at wot it would even stall, i think.
 
1 - 6 of 6 Posts
Top