Hyundai Tiburon Forums banner
1 - 19 of 19 Posts

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter · #1 ·
Hey guys I just got my alpine stage 1 supercharger installed and put about 400 miles on it I opened my hood this morning and saw that my supercharger was rubbing up against a part of my hood and completely rubbed off the paint and now there is bare metal exposed there. It's about the size of a dime where there is no paint. Also a little bit of the superchargers paint is all been rubbed off and the bolt that hold on the throttle cable pulley on the supercharger punched a hole through the black clothlike cardboard cover on the inside of the hood. Is this normal for the supercharger to rub like that. Right now I only have one press one insert in the front of the car and the supercharger has not hit the firewall yet. I have motor mounts from kspec comming in but they are taking FOREVER to get here. Anyone else have problems with their SC rubbing up against the hood? :3_nooo:
 

·
Registered
Joined
·
4,475 Posts
That's common. I just mentioned it in another thread. I think what you're describing is the typical throttle body rub. The fitting on top of the TB bumps under the rear skeleton of the hood. Sofakingrich and I took my ball pean hammer and tapped a small indentation on his under-hood and mine where it bumps. We both have full poly front & rear motor mounts.

I f what you're describing is the motor mount "insert", I wouldn't run with those even for the weekend. They don't stay put and come undone. Get a full poly in there soon.
 

·
Registered
Joined
·
3,879 Posts
You should probably take it easy since you don't have the proper motor mounts yet. S/C smacking the hood or f/w isn't good.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter · #4 ·
Yeah i've been waiting for full motor mounts from kspec that i ordered at the end of november and they still won't come. :3_nooo:
 

·
Registered
Joined
·
3,879 Posts
yellowtibby said:
Yeah i've been waiting for full motor mounts from kspec that i ordered at the end of november and they still won't come. :3_nooo:

Damn,
I'm guessing that I really did get lucky. I got mine in a little over two weeks. I ordered them at the end of Nov. also.
 

·
Registered
Joined
·
9,504 Posts
I think KSPEC is going under, PM me if you want more info. I would suggest doing a chargeback on your credit card and quick.

As for denting your hood to keep from clearance issues that is nuts. I never had any but I did raise my hood up in the back about 1/4" to let the heat out. It cost me about $2.21 by going to Lowes and buying a few longer bolts and some washers.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter · #8 ·
Mr.Photoman I tried PMing you but your mailbox is full clear it so I can get more info. Thanks
 

·
Registered
Joined
·
2,828 Posts
I didn't have the rubbing problem. Dave was just at my house and I was suprised to see how bad it was. A couple of smacks with a ball-peen nhammer did the trick. Another thing, the bolt that holds the wheel for the cruise control cable on the blower poked a hole in the hood insulation. In all honesty the more Alpine installs I do, the more disapointed I get in their quality.
 

·
Registered
Joined
·
750 Posts
I'm sorry, but Kspec isn't going anywhere. Why do you keep slandering the company? Our "sent out list" has been regularly updated, and I got a post on our forums from this gentleman today asking about his items. I don't know his name and directed him to look at our "Sent out list", but as usual, this time of year items can take longer to make it half way around the world than normal.

Please let me know if your items don't arrive within a day or 2 after Christmas my man, I'll look further into it. Also, I'd recommend you check our sent out list to see when your items were shipped. If you bought them the last week of November, they should be there any time now.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter · #13 ·
Well I just talked to redzman and he seemed really helpful and optimistic about my order being sent out late november or early december. I can understand there being shipping delays over the holiday season so I'll wait a little longer. I feel pretty assured that I'll get my product soon and redzman really seemed eager to help me get my stuff. So i'm not too worried. I need these mounts so my supercharger does slam into stuff that would be no good. :3_headsha
 

·
Registered
Joined
·
9,504 Posts
Not to bump an old thread (and definately not to start trouble) I just wanted to point out that I was speaking the truth about KSPEC and I was only trying to be helpful to members by warning them in advance.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter · #15 ·
hopefully my mounts will come in soon lol....as in they will prolly never come in and i'm just hoping..
 

·
Registered
Joined
·
1,614 Posts
i don't know what bad you think about kspec, they always helped me out with info and when i ordered a month back a mount and the strutbar it went there surprisingly fast, although i was subject to custom duty $50 because of some misunderstanding and carrier company differences. but i can't blame kspec, they did a good and fast job.
 

·
Registered
Joined
·
486 Posts
i;'ll go with RRM when i get my motor mounts, but Kspec was very helpful when i bought their sticker for my engine bay, lol... it's just a "korean performance" sticker.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top