Hyundai Tiburon Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
373 Posts
Discussion Starter #1 (Edited)
Ark STS 6-Spd install gone wrong... shifter pops out. Help! :(

Hi Guys,

I just installed my Ark STS on my 6-speed and loved it for the brief moment that i was able to use it... until it popped out of its place this morning on my way to work. It seems that the popping out occurs in the small ball and white clip circled in the pic. circle B on the picture.

When it pops out, everything just gradually slide off (by everything i mean the spring, the black rubber thingy and so on)





I did the install myself, and put everything back the way it was.

I spoke to a guy, and he said he will fabricate some plastic for insertion between the plastic and metal space on circle A. will that work?

Is it possible that my clip in circle B is broken?

or maybe i didn't push the ball into the clip in circle B hard enough? i didn't hear any pops.

thanks.
 

·
Registered
Joined
·
3,615 Posts
I have the ARK STS and never had that problem. Put it in my 03 and now it's in my 05. When you put that part into place you should feel it pop in, if you don't then you didn't get it in all the way and probably that's why it came out.
 

·
Registered
Joined
·
373 Posts
Discussion Starter #4
Hi Guys thanks for the feedback., i've updated the pics. I've tried pushing the B part in further than it is but it won't go further than it is on the picture. And the Part A keep sliding around. So i'm having a custom plastic ring fabricated and i'm planning to put it in the space visible in the A part between the metal thing and plastic thing.

or should i try pushing the ball part further into the plastic on the A part?

herbtea, i didn't hear a pop... is it really difficult to push the ball into it? maybe i didn't push it in hard enough?


thanks guys for the feedback.
 

·
Registered
Joined
·
373 Posts
Discussion Starter #6
Hi Ark, thanks for posting that pic, it cleared things up.

Can someone please post pic with that spacer in the correct place? a pic of the STS installed correctly with all these parts visible?

Thanks guys.
 
1 - 6 of 6 Posts
Top