Hyundai Tiburon Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #1 ·
ok! I've been having suspension noises and problems since ... long time ago...

I've had problems with swaybar bushings, several endlinks replacements, lower control arm bushing replacements... bla bla bla... still having bunch of noises...

1- in my front left wheel, everytime I go by a speed bump (slowly) it sounds like something is loose. The mechanic says that is not the shock, but... man... countless diags and Im about to get some sort of "Hyundai Tiburon Suspension for Dummies" to tear down the whole thing and see whats going on by myself.

2- My house is on a hill, when I enter the garage which has some inclination, I can hear my rear end making noises like it is moving/twisting/[email protected]#$%^. Makes me feel like my car has been glued together LOL!

Well... how do I know if my shocks need to be replaced, and is that noise from the rear end normal?

Cheers!
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #4 ·
replacing the whole suspension , I've thought about that several times.. but what if after doing it, sound persists....... I would probably push my car right into the ocean LOL
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #6 ·
65200 miles... not suspension mods
 

·
Banned
Joined
·
3,990 Posts
If you have replaced your swaybars the rear creaking is probably your swaybar mount bushings. Lube them up. Also make your swaybar hasnt walked off center that will cause noises aswell. Something loose in the front end is far too vague. Could be a noisy tophat if it sounds like its coming from the strut tower. Take it off and lube it. If its a popping noise it could be control arm ball joint.
 

·
Registered
Joined
·
2,445 Posts
long time admirer of you avatar, now that its animated, i'd have to say its one of my very favs

push the car off the cliff buddy, save yourself the aggrivation.

J/K

still dealing with my own noises
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #9 ·
Wagtoda3rd
Rear swaybar bushings were replaced somewhere around Feb and March this year. Also replaced the front swaybar bushings... replaced both set of swaybar enlinks and replaced the control arm bushings.
I'll check the swaybar to see if it is centered. I have never worked in suspensions but i think it's about to start. Regarding the "loose" thing, it is in the front suspension... but to be honest with you, an exact description will be kinda difficult. thanks for the suggestions.

Parfaux

haha thanks! I had to do some work with it since the whole animations was 1mb and the site only allows 19kb...

The car is not THAT bad... I have not had any major engine or transmission problem.... but this little things like noises, suspension and eletrical problems... will eventually drive you nuts!!! If I had the money, I would have pushed it right into the bay.

Btw! Wagtoda3rd... dont you wanna that STI for my Tib?! LOL!
 

·
Registered
Joined
·
1,068 Posts
those noises can definitely be a strut. I have had a stock strut that made some noises over speed bumps. I replaced the mounts and the sway bar link, it was still there, but when I replaced the strut the noise went away. that being say, buy some of suspension parts that are for sale, lol.

http://newtiburon.com/forums/showthread.php?t=166124
:3_pimatyo
 

·
Banned
Joined
·
3,990 Posts
Wagtoda3rd
Rear swaybar bushings were replaced somewhere around Feb and March this year. Also replaced the front swaybar bushings... replaced both set of swaybar enlinks and replaced the control arm bushings.
I'll check the swaybar to see if it is centered. I have never worked in suspensions but i think it's about to start. Regarding the "loose" thing, it is in the front suspension... but to be honest with you, an exact description will be kinda difficult. thanks for the suggestions.

Parfaux

haha thanks! I had to do some work with it since the whole animations was 1mb and the site only allows 19kb...

The car is not THAT bad... I have not had any major engine or transmission problem.... but this little things like noises, suspension and eletrical problems... will eventually drive you nuts!!! If I had the money, I would have pushed it right into the bay.

Btw! Wagtoda3rd... dont you wanna that STI for my Tib?! LOL!


Check to make sure everything is torqued correctly. Sometimes the bolt on your endlink will come loose. That could give you a loose feeling aswell. Lube the swaybar bushings anyways just to make sure it didnt dry out for some reason. Lube your tophats and retorque everything.
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #12 ·
I'll do that... and I've had problems with that endlink bolt getting loose and messing up the endlink.

When you say lube the bushings... how's that? remove the bushing, put some white lithium grease in the inner part and put it back in? sorry if it is a dumb question but I'm trying to learn as much as I can about suspension to work on it myself...
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #14 · (Edited)
I'll do that. And talking about lubing the top hat, I just remote the plastic cover and pour a bunch a withe lithium grease? Is it something else in that strut tower that needs to be greased. Just wanna make sure I take care of everything at one time.

Btw. How good are those Subaru OEM BBS rims?? Here is a guy who's selling them with 235/45 tires for $690.
 

·
Banned
Joined
·
3,990 Posts
Yeah grease where the tophat goes onto the strut. As far as the stock BBS. Its a 17x8 forged wheel that weighs somewhere in the range of 15lbs. They cost over $800 new from the dealer.....per wheel. Super high offset though I doubt you would have enough clearance on the strut side. The wheels would be really sunk in the fenders.
 

·
Registered
Joined
·
1,492 Posts
Discussion Starter · #16 · (Edited)
here is the pic of a Tib that belonged to a friend (r.i.p.) I dont reaaallyyyyyy like the way they look on the car... but if the price is a good deal for a set of good wheels... wth

 
1 - 17 of 17 Posts
Top