Hyundai Tiburon Forums banner

1 - 20 of 20 Posts

·
Banned
Joined
·
108 Posts
easy way to find it ... pull them out one by one .. thas wut i did .. if i remember correctly its towards the bottom half of the box inside ur dashboard
 

·
Registered
Joined
·
205 Posts
It's the one in the yellow cover. It's kind of a pain to get out but it's yuor BCM fuse. You should have some spares that came with the car. Just slap a new one in there. Should work just fine.
 

·
Registered
Joined
·
205 Posts
Look on the cover that you pulled off of your fuse panel (the one in the car by th clutch, not the one under the hood) There should be a line of fuses listed as "spare" just make sure you use the right one. Make sure the numbers match up to the one you pulled.
 

·
Registered
Joined
·
371 Posts
Discussion Starter #7
Aight I appreciate the help I just wanna get the thing back to working condition, I just got my whole exhaust system put in today, and AEM CAI, got the works done all in one day hehe....then i blow my fuse....lol, oh well the fuse is a red-10 i'll go check it now thanks again!
 

·
Registered
Joined
·
205 Posts
No worries. I spent a whole day doing the sound deadening in y car. I was exhausted then I accidently grounded my trunk light on the frame and blew the BCM fuse (just like you did) but I didn't know what it was and I freaked out. I needed to go to work the next day. I didn't know that yellow think could be opened so I pulled every other fuse and they were all fine. Then I found out about this one little fuse that controls everything in the car. It's a ery satisfying feeling when things start working again. I panicked, I thought I'd caused thousands of dolars in damage to my brand new car. Hope it works for ya.
 

·
Registered
Joined
·
205 Posts
SyndicAte said:
Yeah....didn't see anything labeled "Spares" so I didn't pull anything out, any idea exactly where they are?
I belive it's the last line along the bottom. It's either there or along the top. They are all together.
 

·
Banned
Joined
·
609 Posts
hey man i did kind of the samething about a week ago i took my trunk light out and put a new bulb back in while my car was running and the radio was on everything went dead my radio,map lights,locks,clock, and my AC read celsius
i didnt know which fuse to replace so i just took it to the hyundai dealer..It was cool they fixed it for free
 

·
Registered
Joined
·
205 Posts
jonnyd said:
hey man i did kind of the samething about a week ago i took my trunk light out and put a new bulb back in while my car was running and the radio was on everything went dead my radio,map lights,locks,clock, and my AC read celsius
i didnt know which fuse to replace so i just took it to the hyundai dealer..It was cool they fixed it for free
It's easier to figure stuff out in celcious anyway. Did you heat turn all the way up and you fan on full blast wit hthe A/C on too?
 

·
Registered
Joined
·
1,415 Posts
just wondering what blew it ?
i hooked up some neon in my trunk and i spliced it into the OEM trunklight and my tibby was blowing that fusde worse then micheal jackson at a boyscout slumberparty

and also , if you really want to know , yer manual tels you the bottom line are all spares
but then , who would ever think of checking the manual
 

·
Lighting and Accessories
Joined
·
10,468 Posts
diymirage said:
just wondering what blew it ?
i hooked up some neon in my trunk and i spliced it into the OEM trunklight and my tibby was blowing that fusde worse then micheal jackson at a boyscout slumberparty

and also , if you really want to know , yer manual tels you the bottom line are all spares
but then , who would ever think of checking the manual
Old thread, but...

you probably had a positive wire getting grounded- as in- touching metal.
 

·
Registered
Joined
·
1,415 Posts
i suck at reading dates ;) its the stupid english system man , month day year , theres no logic in it

at any rate though , i hooked my neon back up in my trunk , this time without the stock bulb and i havent had any problems yet
 
1 - 20 of 20 Posts
Top