Hyundai Tiburon Forums banner
1 - 5 of 5 Posts

·
Registered
Hyundai Coupe 1.6, 2005
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,
Last year I had a problem with gears in my Hyundai Tiburon GK 1.6 2005 (officially Coupe, I am from Europe, and my car is from Italy). So I left it waiting for better days by my house. It waited there all winter. In January I was still able to start the engine, but somewhere in February I found battery dead. I charged it, put in and... the engine is cranking, but not starting. I didn't need it back then, so waited till the spring comes. Recently I tried to start it but still no success.
I plugged OBD2 scanner and found P1610 error code. That makes sense, because engine don't start, windows won't open and cannot open/close car from the remote.
I tried to start car using spare key - no success.
I googled through the internet and found that the immobilizer problem may be tough to overcome. But when I put key in and rotate, I don't see any light on dashboard indicating that there may be a problem with immobilizer.
I noticed, that previously, when the car was working, there was a green light circle around the key hole. Right now there is no light. So I came up thinking that maybe it is just a problem with that part, some antenna around the keyhole or something.

What do you guys think? Do you have any ideas if it is just some minor issue, or whole immobilizer/ecu/bcm?
 

·
Registered
Hyundai Coupe 2.7 2002 & Hyundai Coupe 2.0 2007
Joined
·
103 Posts
I would check all the connections for the battery, all fuses and most probably buy a new battery.

Immobilzer just wont allow the car to start but all lights would work and power locks etc.
 

·
Registered
Hyundai Coupe 1.6, 2005
Joined
·
3 Posts
Discussion Starter · #3 · (Edited)
To be clear - lights on dashboard work. Radio works, interior lights etc. I had on mind that I didn't see any control light like this:
1624429497046.png


I checked all fuses and they seem to be ok. I will try to check connections between key hole section and battery.
 

·
Registered
Hyundai Coupe 1.6, 2005
Joined
·
3 Posts
Discussion Starter · #4 ·
Hey, did some more checks today. Plugged in brand new battery. Tried to turn on almost all things in car, strangely some work and some not.

Working:
  • Interior lights
  • Radio
  • Clock
  • Dashboard
  • Air cooling
  • Wipes and washer nozzle
1626458084775.png 1626458103214.png


Not working:
  • Hazard lights!
  • Any of the front/back lights
  • Blinkers
  • Ignition switch light
  • Windows
  • Locks


Can it all be the cause of faulty immobilizer or some strange power cable problem? Do you have any ideas where should I start? Or is it time to say goodbye to my car?
 

·
Registered
2006 Hyundai Tiburon SE
Joined
·
622 Posts
If one link in the IMMO chain is malfunctioning or not communicating you won't be able to start the car. There is the immobilizer inside of the BCM which is linked to your ECM, key transponder and key itself. Often times the transponder antenna breaks or the transponder itself fails. If you have a Hyundai specialist in your city or country they should be able to replace and reprogram these components relatively easily.

If you are unable to troubleshootthe IMMO issue with the help of a Hyundai specialist, try replacing the BCM and ECM with a US spec car that doesn't have the IMMO enabled. That should eliminate the immobilizer completely. However it should be noted that we did not receive the 1.6L motor so our 2.0 ECMs from the US may run richer than you want.
 
1 - 5 of 5 Posts
Top