Hyundai Tiburon Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Has anybody tried any of the cheap clutch kits that are around. I see that Kspec has a 4 puck clutch that is supposedly rated up to 400 hp, selling for $799 including a flywheel. I was plannin on going with the Clutch masters setup but this is quite a bit cheaper. Does anybody have any comments on this VHR system or any others? http://www.kspec.com/list.php?ac_id=81&ai_id=445
 

·
Registered
Joined
·
5,722 Posts
ok, well, dont go with what I have lol..........you should look into clutchmasters stage 4......and you might as well get a new flywheel too......they cannot resurface stock flywheel....plus, like fidanza, all you have to do is replace the part, not the entire flywheel....sorry man, i dont think there is a cheap way outta it, considering you are going for F/I
 

·
Registered
Joined
·
7,142 Posts
Look up http://www.dxdracingclutches.com/home.html. It's South bend clutch. They are cheaper than clutchmasters and they're clutches will work with fidenza. Give them a call, they are very friendly and helpful. Ive been on several forums for different cars and have heard very good things about them. I ordered my setup a couple of days ago. I'm sure other brands are good too. I was very close to going with Clutchmasters but went wit south been because they're a good deal cheaper
 

·
Registered
Joined
·
7,142 Posts
I don't know how that is cheaper? I got my fidanza and CM stage 4 from ultarev for about $850 incl. s/h.
I paid for the cryogenics process on the clutch and flywheel though. When I reserched the clutch and fidenza flywheels at South Bend are a cheaper then what ultrarev quoted me.
 

·
Registered
Joined
·
5,243 Posts
How are you liking it?
I love it, and it's not that bad for daily driving. I give it barely any throttle in 1st and it takes off fine. It's been shifting smoother than the oem did. For some reason 4th gives me some trouble when I get on it hard, but I doubt that's a clutch issue, and my synchros were fine before the install, so it may be a linkage problem. Otherwise, 4th is smooth regular driving. All in all, I'm wanting to get a new dyno. I 'm sure the last was inaccurate whe it was on the oem clutch.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top