Hyundai Tiburon Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,607 Posts
Discussion Starter · #1 ·
Im at wits end here. 2003 tiburon I4 base model
Here is the problem, couple weeks ago my head gasket blew. when it blew it pressurized the block and blew the block heater out of the block. long story shot, got it fixed. but ever since my heater hasnt worked quite right.
i get lots of nice hot heat while driving down the road but when i stop at a stop sign or red light the heat goes from hot.....to warm.....to cool.... in about 15 secconds. the thermostat has been replaced so its not that. it was replaced about 2 days before the head gasket was replaced tho. (my dealership refused to admit it was the head gasket) the car heats up to normal temp while driving and does not over heat. it does on occation get a tiny bit cooler than normal. normally it stay's about 1mm away from the 1/2 mark but once in a while it will go to about 3/8. reguardless i think i've got some kind of nasty coolant bubble in the heater vent but i cant get it out. i tried running the car without the rad cap on but it didnt do anything at all. if im at a red light and its cold and i rev the motor to about 2-3000 rpm it gets warm again.
HELP!!!!! WTF is going on with my danm coolant system?????
 

·
Registered
Joined
·
1,607 Posts
Discussion Starter · #2 ·
I think i just found the answer on a ford torus forum.
Backflush the heater core with a garden hose. rad get's back up with debries and stops working well.
Beauty. Ima do that 2nite.
 

·
Registered
Joined
·
1,835 Posts
Good luck man!!! I airlocked my Tib's coolant system once. It took 3 hours and 3 gallons of coolant to correct it(My friend and I had never seen anything like that, and we're both mechanics), so I ended up removing the thermostat permanently..(not really an option for you winter drivers, though)

Best of luck to you, and hopefuuly, you can get back into that "I love my car" curve that you were blasted out of....:(

-BRR
 

·
Registered
Joined
·
1,607 Posts
Discussion Starter · #5 · (Edited)
Flushed the core.....
it works a little betta.....but its still not good as new. my coolant looks like someone took a dump in it. the danm dealership changed my headgasket and left the old coolant in there. I cant freaking belive it. Its getting painfull.... now i've gotta 100% flush the coolant so i might as well backflush the heater core again while im doin that. It just hurts me in the brain to think that my dealership was actually that 100% dumb. I've never seen such a hack job in my life!
 
1 - 5 of 5 Posts
Top