Hyundai Tiburon Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 05 tiburon. I bought it from a guy who said everything was working until he had the battery replaced. Some moron out the battery in backwards. Now, the sunroof, a/c, defrost, and hazard lights don't work. Any idea what's wrong, how to fix, and a price range? Please help! Also when I out the 10a fuse into the a/c in the fuse box, and try to turn on the a/c, it immediately blows that fuse.
 

·
Registered
Joined
·
11 Posts
I have a 05 tiburon. I bought it from a guy who said everything was working until he had the battery replaced. Some moron out the battery in backwards. Now, the sunroof, a/c, defrost, and hazard lights don't work. Any idea what's wrong, how to fix, and a price range? Please help! Also when I out the 10a fuse into the a/c in the fuse box, and try to turn on the a/c, it immediately blows that fuse.
try checking the bcm fuse located in fuse panel its the big yellow one. just pull done and fuse comes out
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks I did do that originally. And it made the radio start working and all the lights on the inside. But the a/c, heater, defrost, hazard lights, and sunroof still won't work. Everything else does. Like the windows, mirrors, signals, and dash
 

·
Registered
Joined
·
11 Posts
tbh i would go ahead and replace all fuses that related to what you stated above, if that doesn't do it. you'll prolly need a new ecu due to the battery being installed in the wrong way, im not 100% sure but I'm taking a wild guess here. from my knowledge of battery being installed wrong, it fries wires real quick, i hope that's not your situation. wish i could be more help may the best work out in your end
 
1 - 6 of 6 Posts
Top