Hyundai Tiburon Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4,475 Posts
You didn't fill out your profile section, so I don't know what year tib you have. The manual climate control fans have had trouble. Several of them have burned out if the fan switch is set on 4. One member had his fixed 2x, and then the harness replaced, and it still went bad.
 

·
Registered
Joined
·
513 Posts
I had a problem like this and pulled the middle panel off and looked behind it and saw that some of the wires were touching... I bent them in a way that they weren't touching and it worked again... try that before you spend any $$
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
I had a problem like this and pulled the middle panel off and looked behind it and saw that some of the wires were touching... I bent them in a way that they weren't touching and it worked again... try that before you spend any $$
Thanks for the suggestion, I'll do that. I also noticed that if I put in on the #3 or #4 settings, and push the knob inwards, the fan comes on at that speed. What's up with that?
 

·
Registered
Joined
·
399 Posts
Your fan switch is melting! Seriously, pull off the center dash panel and have a look. I'm on my 5th or 6th switch. The good news is that the switch is only abour $30 at the dealer.
 

·
Registered
Joined
·
399 Posts
This is definitily an issue with the blower motor switches. I'm supprised that Hyundai hasn't addressed it. I guess a few fires will have to start before they are willing to do anything about it. Check the wiring and the terminals inside the connector. Make sure there all ok and have good tight connections. If they are black, or the wires are melted you should replace the harness as well. If you don't the new switch will soon melt again.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top