Hyundai Tiburon Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1,880 Posts
Discussion Starter #1
I received my Fl headlights prewired from Kdmguy for the 04 tib. I installed my halo hids and they didnt work. Now i believe that the wires on the 04 are wired different in that the polarities are opposite of the 05. So i switched the wires so that they went red to black and black to red and they worked. I was wondering if anyone else had to do this. Also when i turn on my high beams my low beams dont shut off. Not sure if this is normal. My guages reset once in awhile right when i turn on my lights. Uneek said that it could be the bcm learning as this happened to him when he first installed his. Regardless im going to get a relay to be safe. Just not sure if anyone else noticed this as well.
 

·
Registered
Joined
·
1,461 Posts
I ran into the same thing when I installed mine. I had the positive going into the relay harness plugged into what I thought would've been the positive wire of the stock headlight bulb harness and my HIDs didnt' work. It wasnt until I thought about the change in wiring colors on the fl headlights that I switched connections from the red to the black, and that worked for me. And yes, when you hit your highs, your lows will come on as well...it's been the same for the 03-04 headlights as well.

As for the gauges doing the blink, definitely get a harness. I've had my HIDs plugged in for a couple of years w/ a harness and have not seen a single reset, blink or bloink of anything electrical in my car since then. Better safe than sorry.
 
1 - 2 of 2 Posts
Top