Hyundai Tiburon Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
259 Posts
Discussion Starter · #1 ·
Wow this was really stupid...pulled out from mcdonalds and my ebrake was up. Didn't notice anything since the car would still move, but when I got on the interstate I noticed I couldn't accelerate past 60. I floored the throttle and the car wouldn't go past ~2500 rpms or 60 mph -- I was like WTF!?!? Then I started smelling something burning and noticed that my ebrake was still pulled up :(.

You think everything is going to be ok?
 

·
Registered
Joined
·
1,818 Posts
Wow this was really stupid...pulled out from mcdonalds and my ebrake was up. Didn't notice anything since the car would still move, but when I got on the interstate I noticed I couldn't accelerate past 60. I floored the throttle and the car wouldn't go past ~2500 rpms or 60 mph -- I was like WTF!?!? Then I started smelling something burning and noticed that my ebrake was still pulled up :(.

You think everything is going to be ok?
If it got too hot, you might have warped the rotors.
 

·
Registered
Joined
·
1,939 Posts
your rotors are probably toast along with your pads since it sounds like you went a little ways
 

·
Registered
Joined
·
5,094 Posts
Speaking of...
Don't mean to get you down, but a couple days ago at work, an 80ish year old women bought a 2009 Cadillac CTS. She paid cash for it, and called us 45 minutes later, the car had caught fire because she left her e-brake on the whole way home :O
 

·
Registered
Joined
·
4,351 Posts
My GTO won't let me drive with the ebrake on... it puts up a visual word warning then starts beeping.. then puts the car in limp mode...
 

·
Registered
Joined
·
259 Posts
Discussion Starter · #7 ·
^haha so no ebrake 180s

anyways, the ebrake works fine now, so I guess it's cool

only drove for like 5 mins.
 
1 - 7 of 7 Posts
Top