Hyundai Tiburon Forums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
1,841 Posts
Discussion Starter · #1 ·
Ok so i got gas last week and went to start it up and it wouldnt start! Finally it started and ran like crap. After leting it sit for a while it started up and ran just fine. Now today i got gas again and it did the same thing! What gives? Anyone have any ideads what getting gas and my car not running has to do with eachother? It runs fine on the gas so i dont think that is it. Also i put in about 1/2 a tank both times.
ken
 

·
Registered
Joined
·
3,233 Posts
Make sure you tighten the gas cap until it clicks a few times. If you don't it can mess with the pressure in the system.

Also, there have been issues when people "top off" the tank after the pump shuts off. Although if you're only filling up halfway it wouldn't be that.
 

·
Registered
Joined
·
1,841 Posts
Discussion Starter · #4 ·
When it runs rough, does it tend to produce some black smoke?
Nope! It just hesitates to start. it will crank but not turn over. Then it starts but runs really bad. The idle is super rough at like 500 RPM's. I was wondering if the gas cap could actualy be bad like maybe it is not sealing. I live in Colorado and it has been super cold lately. It seems like there is a lack pf pressure in the gas tank somehow. But how? I tighten the cap about 3-5 clicks.
Ken

Oh i dont know but this is making me really mad!
 

·
Registered
Joined
·
165 Posts
The same thing happened to me about a month ago and it was diagnosed as a failed purge solonoid. The Hyundai part # was 28910-22040 and the list price was $29.98. If you're not under warranty, expect 2 hours for the labor charge.
 

·
Registered
Joined
·
2,590 Posts
The same thing happened to me about a month ago and it was diagnosed as a failed purge solonoid. The Hyundai part # was 28910-22040 and the list price was $29.98. If you're not under warranty, expect 2 hours for the labor charge.
i was gonna suggest the purge valve as well,

but definately dont pay a 2 hour labor charge,

get the part from lowsonoma1999 for like $20 and do it yourself, it's a real simple install, would take you 30 minutes max
 

·
Registered
Joined
·
2,590 Posts
Is there a guide anywhere on how to install it? Or would i have to buy one of those $100 books that tells me how to do everything on my car?
Ken
seriously, it's really easy,

with just 1 picture to show you where it's attached, you should be good to go,

all you have to do is detach 1 plug, 2 hoses, re-attach to the new one and you're done
 

·
Registered
Joined
·
12,151 Posts
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top