Hyundai Tiburon Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just purchased a SWEET 2004 Tiburon GT 2.7 6 speed. It is all stock. I recently had a problem of coming to a stop and the idle reving to 2500 RPM and staying there. It doesn't do it all the time and it has only done it on warm days at normal operating temperature. I tried pulling up on the throttle pedal with my foot, but that did no good. The dealer has had the car for 3 days and they tell me they can't get it to do it. Anybody have any ideas? Is this a common problem for the Tiburon? Any help[ would be appreciated.
 

·
Registered
Joined
·
705 Posts
I just purchased a SWEET 2004 Tiburon GT 2.7 6 speed. It is all stock. I recently had a problem of coming to a stop and the idle reving to 2500 RPM and staying there. It doesn't do it all the time and it has only done it on warm days at normal operating temperature. I tried pulling up on the throttle pedal with my foot, but that did no good. The dealer has had the car for 3 days and they tell me they can't get it to do it. Anybody have any ideas? Is this a common problem for the Tiburon? Any help[ would be appreciated.
Its probably your throttle cable it may be binding...make sure it is lubed up and not too tight
 

·
Registered
Joined
·
827 Posts
i'd check the throttle cable too
 

·
Registered
Joined
·
2,662 Posts
It could possibly be your IAC (Idle Air Control) valve thats attached to the TB. It plays a vital role at maintaining idle in various conditions like coming to a stop, chopping throttle, etc. and might be sticking open at times. If' it's an 04 (like mine), then it may have quite a few miles. Over time grim from oil vapors being sucked back in through the TB from the valve covers can gum up stuff.

You may want to remove the TB from the intake manifold, remove the IAC and use some TB cleaner and spray the hell out of every nook and cranny. The TB Cleaner should make easy work at dissolving all that crap.

BE SURE to order new gaskets for the TB and IAC. Unlike the gasket for the upper intake manifold to the lower, you can't reuse the TB gaskets. They're cheap anyways. I always order a bunch on Rockauto.com to have on hand.
 

·
Registered
Joined
·
111 Posts
have you checked for vacum leaks in the induction system i had this with mine turned out that the induction pipe had a split in it it just an idea.
regards neil
 

·
Registered
Joined
·
39 Posts
Ya I would also look into a vacuum leak. It can cause a high idle condition.
 

·
Registered
Joined
·
3 Posts
I have a 2005 Hyundai Tiburon 2.7L V6 5 Speed. It idles high at stops and wont idle down past 1100rpms. Replaced IAC, TPS, and PCV. Still nothing. Throttle body is not sticking and closing correctly anyone have any suggestions?
 

·
Registered
Joined
·
1,506 Posts
I have a 2005 Hyundai Tiburon 2.7L V6 5 Speed. It idles high at stops and wont idle down past 1100rpms. Replaced IAC, TPS, and PCV. Still nothing. Throttle body is not sticking and closing correctly anyone have any suggestions?
Vacuum leak? Check hoses, fittings and gaskets. Anything been done recently?
 

·
Registered
Joined
·
120 Posts
It could also be your Evap Purge Valve cuz I know when mine went bad it idled high and everytime I went to pump gas my car wouldn't start I had to rev it and quickly put it in first so it stays on,

The Evap purge valve is located behind the throttle body its a 5 min fix
 

·
Registered
Joined
·
3 Posts
Also replaced MAF and it starts fine doesnt stall out. When I disconect the battery and reset the computer it idles at 750rpms, where it should be, then it will slowly bring itself up to 1100rpms in 15secs of being on. So Im Stumped cause i replaced MAF, TPS, IAC.
 

·
Super Moderator
Joined
·
8,689 Posts
When you disconnect the battery or "clear CEL's" with a scanner, you lose all ECU learning. Depending on the car, it may be a bit wonky until it relearns how to make the engine do what Hyundai wants it to do.

Let it learn for a few days of driving, then get back to us if it's still not correct.
 

·
Registered
Joined
·
1,821 Posts
i had this same problem and believe it or not i changed the temp sensor located under the coil pack.. i had no idea why a temp sensor would do that but it hasnt done that since
 

·
Registered
Joined
·
154 Posts
i have a wierd problem but mine isn't a "high" idle, if i rev it up just a little to start moving (forward or reverse) it sometimes kinda sticks at 1500 rpm and if i don't move it'll come back down in a miute. not sure what it could be..?
 

·
Registered
Joined
·
3 Posts
Yea. I ran it for like a week and it still did the same thing. The temp might be the issue I will try that. I was also told that it could be the purge valve under the throttle body. My friend told me to try to run some brake clean throught it the put it back in any thoughts?
 

·
Registered
Joined
·
2 Posts
Its probably your throttle cable it may be binding...make sure it is lubed up and not too tight
I have an '01 Hyundai Tiburon DOHC V6 5spd it idles high when coming to a stop and also when I start it in the morning it starts but if I don't rev it up to about 2500 rpms it bogs down and dies. I'm thinking the IAC or the TPS. Any suggestions?
 
1 - 20 of 20 Posts
Top