Hyundai Tiburon Forums banner

1 - 20 of 54 Posts

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter #1
Finally after over 3 months of waiting my alpine supercharger has ARRIVED at 9 am this morning. I'm so happy that i'm shaking my money maker like somebody's bout to pay me! I have one question though. I want to purchase te yaya polyurethance motor mounts that are pressed in after the stock mount rubber is cut out. I found these on K-spec but from the pictures they look like it's for the I4 tib. Will these mounts fit the V6? http://www.kspec.com/list.php?ac_id=81&ai_id=1211
 

·
Registered
Joined
·
1,165 Posts
those do fit the v6, but a few members on here have had them and very quickly replaced them with actual motor mounts. I'd look into something a little stronger, such as the Speed Freak Racing mounts or the RIPP mounts. and of course if you have the cash theres always NGM.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter #6 (Edited)
xFloggingkylex said:
those do fit the v6, but a few members on here have had them and very quickly replaced them with actual motor mounts. I'd look into something a little stronger, such as the Speed Freak Racing mounts or the RIPP mounts. and of course if you have the cash theres always NGM.
Correct me if i'm wrong but are these not actual motor mounts? I thought you cut out the rubber of the stock mount bracket and press these into the cavity where the stock rubber mounts used to be. These are not the Howell motor mount press on type that are just two pieces of stiffer rubber that you place over the stock rubber part of the mount.
 

·
Registered
Joined
·
2,656 Posts
Hey yellowtibby, mine just got here today also, they must have shipped out together, from what I've heard, the right way to do the mounts is to replace the whole assy. I don't know who has the best ones, I imagine every shop buys from one or two actual manufacturers. Great x-mas present, although a tad early YEE-HAWW! :3_lijstje
 

·
Registered
Joined
·
4,475 Posts
Those are one of the best poly mounts you can get. I have the yaya's front & rear. They are not inserts, but full poly bushings. The only difference between these:
http://www.kspec.com/list.php?ac_id=81&ai_id=1211

and these:

http://www.kspec.com/list.php?ac_id=81&ai_id=1598

are your not paying for the metal mount you already have. You just have to cut out your old oem bushing and press these in, or buy the complete poly mount if you don't feel like the extra work and don't want to save some money. I've never heard of anyone having a failed yaya. I do think some people confuse the poly bushing with the POS inserts.
 

·
Registered
Joined
·
1,347 Posts
bagpiper said:
Those are one of the best poly mounts you can get. I have the yaya's front & rear. They are not inserts, but full poly bushings. The only difference between these:
http://www.kspec.com/list.php?ac_id=81&ai_id=1211

and these:

http://www.kspec.com/list.php?ac_id=81&ai_id=1598

are your not paying for the metal mount you already have. You just have to cut out your old oem bushing and press these in, or buy the complete poly mount if you don't feel like the extra work and don't want to save some money. I've never heard of anyone having a failed yaya. I do think some people confuse the poly bushing with the POS inserts.
how do you secure the bushing in the metal?
 

·
Registered
Joined
·
4,475 Posts
yellowtibby said:
Finally after over 3 months of waiting my alpine supercharger has ARRIVED at 9 am this morning. I'm so happy that i'm shaking my money maker like somebody's bout to pay me! I have one question though. I want to purchase te yaya polyurethance motor mounts that are pressed in after the stock mount rubber is cut out. I found these on K-spec but from the pictures they look like it's for the I4 tib. Will these mounts fit the V6? http://www.kspec.com/list.php?ac_id=81&ai_id=1211
I got my yaya bushings from KSPEC. Just email them and confirm they're for the 2.7
Glad to see you finally got your sc. I know the feeling. Just about when you get over the waiting, it shows up. You're tib's gonna be a whole new ride.
 

·
Registered
Joined
·
4,475 Posts
chaosripper45 said:
how do you secure the bushing in the metal?
The bushing has ridge on both sides. When you press it in (spray a little silicone on it first or it'll be like prom night) it will seat itself and the ridges keep it in place. There have been different methods to press them in. If you have access to a hydraulic bearing press, great. One guy said he set the bushing on his mount, layed a board over it and drove over it. One member said he laid a board over his, and stood on it. I personally set the mount with the lubed bushing on it, on top of my floor jack, slid it under the frame of the tib, and raised the jack which acted like a press forcing the bushing into the mount.

The hardest part is to take the hacksaw blade off, stick it through the opening of your oem bushing, reconnect the hacksaw, and make a cut through the bushing and the steel rim (not the mount). The stock bushing is like cutting through a steel belted radial tire. Then take a cold chisel or hevay @ss screwdriver and tap it in between the rim and the mount, prying the rim and bending it inwards. After that, just take the hammer and tap out the old oem bushing with the rim around it, and press in the new one. There's a difference between the front and rear. If I remember, the rear has an off center guide.
 

·
Registered
Joined
·
4,475 Posts
MisterTib said:
Hey yellowtibby, mine just got here today also, they must have shipped out together, from what I've heard, the right way to do the mounts is to replace the whole assy. I don't know who has the best ones, I imagine every shop buys from one or two actual manufacturers. Great x-mas present, although a tad early YEE-HAWW! :3_lijstje
Congrats on the sc.
 

·
NT's Medical Student
Joined
·
1,120 Posts
Discussion Starter #13
Thanks alot bag piper you saved me alot of money lol. I can't wait to throw this blower on. i'm so happy i can POOP!
 

·
Registered
Joined
·
2,828 Posts
Dave, I have the kspec mount it works just fine. Only takes about 1/2 to cut out the old mount & press the new one in. I know you're gonna be a PITA to me next weekend when I install that bad boy...LOL
 

·
Former CIO
Joined
·
10,258 Posts
red_tib said:
Geez...how much longer for the rest of the people waiting on the ASSASSINGS.....waiting game is killing me....

wtf? that was out of left field seeing how it is an alpine thread
 

·
Registered
Joined
·
819 Posts
I told you it would be about a 3 month wait, Dave. Glad to hear it finally came in. Jerk! You are going to be faster than me again. Should be a good race. lol. What day is the install? Sat or Sun?

Did you get gauges? New plugs and wires? Oil catch can? or any other new goodies too?
 

·
Registered
Joined
·
8,088 Posts
The majority of the wait for this kit was the ongoing problems with Magnuson. Did you order it direct through Alpine or one of its distribution points?
 
1 - 20 of 54 Posts
Top