Hyundai Tiburon Forums banner

21 - 31 of 31 Posts

·
Always Here To Help
Joined
·
3,920 Posts
So do you think I need to take off that plastic covers the motor or do I just jack the car off..... I mean up and try to get to the sensor from underneath the car?
HAHAHA...... funny stuff right there in bold.

As for the situation, removing the plastics is usually the easiest way to get to the 02 sensors, few bolts and a few pop-screws.... and wallah, they will be off!
 

·
Registered
Joined
·
2,445 Posts
do you know how to take the plastic off? lol, i didn't. The two plastic pieces you have to pop off confounded me. I knew it was still bolted on but i couldn't find any bolts
 

·
Registered
Joined
·
40 Posts
Discussion Starter #23
HAHAHA...... funny stuff right there in bold.

As for the situation, removing the plastics is usually the easiest way to get to the 02 sensors, few bolts and a few pop-screws.... and wallah, they will be off!
Cool beans. I'm gonna try step 1 when I get home just for shiyts and grins. I got the MAF cleaner and filter oil on my lunch break. Oh and a bottle of the lucas oil tuneup junk. The guy talked me into it. CEL light comes back on then I'm going to step 2. I have an Ingen SRI. I think I said 5zigen before.
 

·
Always Here To Help
Joined
·
3,920 Posts
Good luck to you sir..... hopefully that works.... but again, if you're dumping that much fuel, my thoughts are a sensor is fouled.
 

·
Always Here To Help
Joined
·
3,920 Posts
no worries.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #28
Yeah I got that too. I got the plastic part off now I'm trying to find the sensor that is the first one on bank one at the top between the motor and firewall attached to the header. Jack up the car?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #29
well team i found where the sensor was and all that good stuff. I go to hook up the new sensor and the plug won't fit. I guess they gave me the wrong one. I just have to figure out what the right one is. The they gave me is Bosch# 15651 so I'm guessing I need 15654? Anybody have any idea? Oh and i have to clean my SRI filter. It's freaking filthy!
 

·
Registered
Joined
·
200 Posts
I'm about to replace my o2 sensor. (upstream sensor on the front bank). What size sensor socket should I get? Or are they all the same size? Thanks!
 
21 - 31 of 31 Posts
Top