Hyundai Tiburon Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
519 Posts
Discussion Starter #1
HEy I have an 03 tiburong gt so I have the sport tuned suspension. Everytime I go over a bump, even small ones, the right front wheel sounds like its knocking on something. Could it be a blown shock? If not, then what else could it be?
 

·
Registered
Joined
·
1,607 Posts
check to make sure your wheel lug nuts are tight.
If they are tight, while the car is on the ground grab hold of the wheel and shake it as violently as you can. then do the same to the other wheel on the opposite side. if they are open your hood and check all 3 mounting points for the suspension to make sure they're tight. if they are take off the rubber cap in the middle of the 3 points and check the ultra greasynut in there to make sure its tight. if they're all tight jack the car up and take the wheel off. make sure you jack both ens up and support it with jackstands. now get a wire brush and make 10000% SURE you clean off the exposed threads on any bolts you touch here. Alot of people (including myself once) start working on their suspension down here, and they try to unthead a nut over a dirty thread. the nut piles up the sand etc stuck to the bolt and things seize....then they break. now check the 2 bolts that connect the strut to the hub assembly for tightness. also check to make sure nothing is loose to bang around. check the rest of the suspension for being bent etc. lastly check the swaybar links. to do this you have to take it off. start with the bottom bolt link. CLEAN THE THREADS!!!! and you will have no problems with this. also a shot of wd-40 couldnt hurt. then remove the nut and be carefull here as the swaybar may be SLIGHTLY preloaded. nothing dangerous though.....unless you only jack up 1 side of the car.... then yer screwed. once its off just check the endball links to make sure they are tight and such.. when you move the threaded end it should stay where you put it and not spring back to center. If ya dont find the problem, its officially time to take it in cuz im stumped.
 

·
Registered
Joined
·
292 Posts
Well you have a couple thig's
1.Check bushings
2.Ball joint's
3.Strutt mount
4.Tie rod end(iner or outer)
5.Bad strut
or
6.Something is lose.
Good luck!!!
 

·
Registered
Joined
·
419 Posts
ok, i'll take a stab at this too, as possibilitys:
1. bad sway bar links
2 bad strut mounts
3 ball joints bad
4 worn struts
5 loose control arm bolts
6 loose brake caliper mounting bolts
7, ummm, i think thats all ive encountered as problems on cars before
really, if ya dont know what it is, take it to a shop, be safe than sorry
 

·
Registered
Joined
·
358 Posts
are you sure that's were it's coming from? sounds can be decieving, look under your car and see if anything is visably scratched or dented ( specificly your exhaust )
 
1 - 5 of 5 Posts
Top