Hyundai Tiburon Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
has anyone heard of the problem with one of the turn signals staying on ALL the time? i mean, with the car off, keys out, everything. this happened to me before, and i took it to the dealership. apparantly, the signal relay is part of the BCM, so they were gonna replace that, but it went away before the dealership put in the BCM. they put it in anyway. now it's happening again....but i'm out of warrantly and it's an $800 part. any thoughts?

rivum
 

·
Registered
Joined
·
690 Posts
rivum said:
has anyone heard of the problem with one of the turn signals staying on ALL the time? i mean, with the car off, keys out, everything. this happened to me before, and i took it to the dealership. apparantly, the signal relay is part of the BCM, so they were gonna replace that, but it went away before the dealership put in the BCM. they put it in anyway. now it's happening again....but i'm out of warrantly and it's an $800 part. any thoughts?

rivum
It is the BCM, i had this problem last dec 2003 signal stays on solid with the car off and key out......it is the BCM and nothing else...you probably got a bad BCM, they warrenty sure extend if the replacement part breaks
IE you get it done the 3 months later it goes again but you are over the km's thats gay fight with the dealer to have them replace it again :3_yes:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
yeah i talked to the dealer that installed it and they can't do sh*t for me...
i'm gonna have to get in touch with the head office i guess :2_confuse
thanks for the info adam

rivum
 

·
Registered
Joined
·
12 Posts
Rivum: I had the same problem with my GSR 2003 last September with the left turn signal staying on when I was driving and the dealer replaced the BCM in my car under warrantee as I had less than 20,000 km. However it only stayed on while I was driving.
But I was told by my dealer that another Tiburon GSR 2003 was brought into my dealership by a tow truck the day before I came in because his left hand turn signal kept flashing on and off even when the car was turned off. The owner went into work and it kept flashing and when he came out his battery was dead hence the tow truck. My dealer said that they return the defective BCM's to manufacturer so that they can find out what is causing the problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
CARCHARIAS said:
Rivum: I had the same problem with my GSR 2003 last September with the left turn signal staying on when I was driving and the dealer replaced the BCM in my car under warrantee as I had less than 20,000 km. However it only stayed on while I was driving.
But I was told by my dealer that another Tiburon GSR 2003 was brought into my dealership by a tow truck the day before I came in because his left hand turn signal kept flashing on and off even when the car was turned off. The owner went into work and it kept flashing and when he came out his battery was dead hence the tow truck. My dealer said that they return the defective BCM's to manufacturer so that they can find out what is causing the problem.
thanks for the info carcharias
i still haven't had a chance to do anything about it yet...too much other crap going on right now!
i've just been leaving it on while i'm driving and then disconnecting the battery when i'm out. certainly not an ideal situation...got to get this sorted soon!

so exactly how many people have had this problem? sounds like there should be some kind of recall if there's alot, as it's clearly a safety issue.
maybe if enough people have had this problem, it will swing some weight my way.
chime in, please!

rivum
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
something else i'm thinking - for those of you who have had this prob, did you by any chance disconnect the brown wires to the side daytime running lights? wonder if maybe that may have something to do with it for some reason

rivum
 

·
Registered
Joined
·
690 Posts
rivum said:
something else i'm thinking - for those of you who have had this prob, did you by any chance disconnect the brown wires to the side daytime running lights? wonder if maybe that may have something to do with it for some reason

rivum
NOPE....mine was the BCM.....its a silly thing Hyundai did.....all electronic run through this BCM, even the signal relay.....if the signal relay goes bad the WHOLE BCM must be replaced.....sorry dude, i have mine done under warrenty xmas 2003....4 months after i got the car.... :3_yes:
 

·
Registered
Joined
·
32 Posts
Ah hell Rob just kick it! LMFAO Sorry, I'm just a little nutty today. Wish I could help you out though sweetie.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
well, here's an update on this...
it randomly fixed itself on the weekend.
my soon-to-be mother in law drove my car and the next time i drove it, it was fine.
figure that one out.
mothers-in-law are good for something i guess!

rivum
 

·
Registered
Joined
·
14 Posts
yup its the bcm, i got a call from hyundai canada, asking me to bring my car to the dealership to see if i was one of the lucky sasseptable participents, but since my car was built after the date in ? no work needed to b done
 

·
Registered
Joined
·
300 Posts
rivum said:
has anyone heard of the problem with one of the turn signals staying on ALL the time? i mean, with the car off, keys out, everything. this happened to me before, and i took it to the dealership. apparantly, the signal relay is part of the BCM, so they were gonna replace that, but it went away before the dealership put in the BCM. they put it in anyway. now it's happening again....but i'm out of warrantly and it's an $800 part. any thoughts?

rivum
i had the same problem, but on the right. i had to wait to long for an appointment so i took out the bcm, rapped on the relays with a screw driver and put it all back together. haven't had the problem since. sounds like a sticky relay.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
smg72266 said:
i had the same problem, but on the right. i had to wait to long for an appointment so i took out the bcm, rapped on the relays with a screw driver and put it all back together. haven't had the problem since. sounds like a sticky relay.
:2_eek:
really? i'll have to try that if it ever pops up again.
thanks for the tip!

so far so good...it's still fine. strange.

rivum
 

·
Registered
Joined
·
7 Posts
Discussion Starter #15
hoju said:
yup its the bcm, i got a call from hyundai canada, asking me to bring my car to the dealership to see if i was one of the lucky sasseptable participents, but since my car was built after the date in ? no work needed to b done
you mean to tell me that they would have done the work for free on your car (if it were the right date), and i couldn't get anyone to listen to me about fixing it for free??
that's bureaucracy for ya!

it's nice to see that they're recognizing that it's a problem, though, so at least people won't have to worry about it in the future!

rivum
 

·
Registered
Joined
·
14 Posts
go to any search engine and type in hyundai tiburon recals, if the part was recalled then they should be changeing it for free regardless of warrenty
 

·
Registered
Joined
·
1 Posts
thanks for the info carcharias
i still haven't had a chance to do anything about it yet...too much other crap going on right now!
i've just been leaving it on while i'm driving and then disconnecting the battery when i'm out. certainly not an ideal situation...got to get this sorted soon!

so exactly how many people have had this problem? sounds like there should be some kind of recall if there's alot, as it's clearly a safety issue.
maybe if enough people have had this problem, it will swing some weight my way.
chime in, please!

rivum
I have a 2003 tiburon gt and this just started happening to me.First it seemed like one of the bulbs was bad because the left signal would not work.I bought some bulbs and befor I had a chance to change them out the signal inside went on solid and now I have removed the hazard fuse and have no signals at all.Sucks!
 
1 - 17 of 17 Posts
Top