Hyundai Tiburon Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2008 GT v6 Automatic. Suddenly the other day, when I put the shifter into manual mode, sport mode, whatever you want to call it, It suddenly stopped working on the upshifts. I can still downshift, but when I upshift, it just throws it back into drive. I assume this is some sort of fallback incase something fails. Has anyone seen this issue before? I am not even sure where to start looking to resolve this.

If this issue exists somewhere else, please link me to it. I was unable to find a successful result for my searches for this issue. Thanks
 

·
Registered
Joined
·
1 Posts
I’m having this exact same issue with my automatic 2008 GS. I believe that it’s one of the shift solenoids going out, but I’m not 100% sure, as when the car is in drive it shifts relatively okay, a little late and a little clunky, but it’s functional enough for me to daily it. If you figure anything out let me know as i would love to get this fixed
 

·
Registered
Joined
·
54 Posts
I have good news and bad news … I’ve ran into this shift tronic issue with my 07 auto many many moons ago … The good news is it’s an automatic and even with the manual not working… it’s still an automatic… doing its automatic magic….. And here comes the bad news… it’s not the solenoid … It’s somewhat of a rubber piece that goes aground the shaft of the shifter … you can’t see it unless you take the whole assembly out which is relatively easy….. so that’s the issue bc it’s worn and most likely on borrowed time.. Best thing to do is replace the whole shiftronic assembly… you can attempt to try and fix that rubber piece but its made out of some cheap teflon bs.. and will just fall apart … ebay will be your best option or a local junk yard might be another.. best of luck
 
1 - 5 of 5 Posts
Top