Hyundai Tiburon Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
4,614 Posts
Discussion Starter · #1 · (Edited)
This was probably one of the easiest installs I've done on the Tib. While the car was on the lift it took a total of about 25 min to replace both the front and back.

The only kinda hard part of the install is getting the three bolts out of the rear mount. Those things are in there solid with blue locktite.

The mounts really change the feel of the car if that makes any sense. Before the install, at idle while in the car, it was really smooth. The mounts give the car a more rugged type of feel because you're feeling the movement of the engine through the frame. It's not a bad thing. Just a totally different feel from what the stock mounts offered.











 

·
Registered
Joined
·
938 Posts
What brand did you get? How are they working for you? Thinkin of getting some soon.
 

·
Registered
Joined
·
960 Posts
yeah i know what you mean.. i did mine before i just got deployed so that would make it..... thursday i put them in... those 3 bolts were in there tight!!! at 1st my 1st thought was they were stripped into the frame but after seeing all 3 that tight, i knew they were just in there tighly... it makes a nice difference i think.. you get a little shake inside the car but it's really not THAT bad... plus when your driving the shake goes away mostly... and it really isn't a tough install, i thought it just took the longest to get the bolts off the front motor mount because of the limited space for the ratchet/wrench to rotate... other than that.. WAY worth it to do the upgrade, wouldn't you say
 

·
Registered
Joined
·
4,614 Posts
Discussion Starter · #5 ·
yeah i know what you mean.. i did mine before i just got deployed so that would make it..... thursday i put them in... those 3 bolts were in there tight!!! at 1st my 1st thought was they were stripped into the frame but after seeing all 3 that tight, i knew they were just in there tighly... it makes a nice difference i think.. you get a little shake inside the car but it's really not THAT bad... plus when your driving the shake goes away mostly... and it really isn't a tough install, i thought it just took the longest to get the bolts off the front motor mount because of the limited space for the ratchet/wrench to rotate... other than that.. WAY worth it to do the upgrade, wouldn't you say
Definitely worth the install.
I got the front off really easy. I just used a short ratchet w/ 14mm socket and a short 14mm wrench.
 

·
Registered
Joined
·
960 Posts
Definitely worth the install.
I got the front off really easy. I just used a short ratchet w/ 14mm socket and a short 14mm wrench.
i just had trouble with the 3 bolts holding the mount onto the frame... well the bolt in the rear of the front mount came out easily and was easy to get to but the other 2 that were BESIDE the mount and on the top part of the frame just took a while to unscrew cause of the limited movement with the ratchet.... idk it was still so easy and WELL worth it
 

·
Registered
Joined
·
3,601 Posts
yay! hahaha i have inserts right now (they pretty much lick my dogs sack) I have full mounts on the way from Seoulfulracing. Im so excited, My only advice to those who read dont buy inserts they are a waste of money they squeek and if SUCKS lol.

congrats on the install tho man i cant wait till mine come in. Good to see you got ur headers finished as well.
 

·
Registered
Joined
·
4,614 Posts
Discussion Starter · #10 ·
Your exhaust is so nice and shiny!

and btw when you remove the mounts does the motor move at all?
When you remove the front, it doesn't move at all. When you remove the rear, it drops about an inch, but it's still easy to get the mount back in. I had to use a tranny jack to push the motor back up so that I didn't strip the bolts putting them back in.
 

·
Registered
Joined
·
1,731 Posts
i got some inserts but ill probably only do front sense NA anyways. may not do them at all if i decide to sell soon. Those mounts look great and ur exhaust looks nice too
 

·
Registered
Joined
·
1,219 Posts
Nice pics. Kspec makes some good mounts. I still haven't put the rear one in, but it's sitting in the garage.

Did you put locktite back on the threads? Red or blue?

I didn't use any when I put my front mount on... oops... think I should be worried?
 

·
Registered
Joined
·
1,720 Posts
I was planning on doing these in the next two days. My only problem is that I don't have a lift so it would take longer working on my back in my cold garage in Chicago. My other problem is I have to schedule with Hyundai to get my parking brake cable fixed. I am not sure if I want to be under my car with no parking brake. My KSports would gaurantee that my head would be crushed if my car slipped.

Quick question - only the last 2 pics are the front mount right, the other five are all rear mount.
 

·
Registered
Joined
·
4,614 Posts
Discussion Starter · #16 ·
Nice pics. Kspec makes some good mounts. I still haven't put the rear one in, but it's sitting in the garage.

Did you put locktite back on the threads? Red or blue?

I didn't use any when I put my front mount on... oops... think I should be worried?
I didn't put any back on.

I was planning on doing these in the next two days. My only problem is that I don't have a lift so it would take longer working on my back in my cold garage in Chicago. My other problem is I have to schedule with Hyundai to get my parking brake cable fixed. I am not sure if I want to be under my car with no parking brake. My KSports would gaurantee that my head would be crushed if my car slipped.

Quick question - only the last 2 pics are the front mount right, the other five are all rear mount.
Yea,
The last two are of the front mount.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top