Hyundai Tiburon Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
551 Posts
Discussion Starter #1
I ordered the entry level kit and 2 weeks later it arrived at my shop.It only took around 5 hours to install.The only problem I had was with the wiring harness.The car would not start.After a few hours we thought there was something wrong with the unichip.Dave and John talked to me the entire time while trying to diagnose the problem.They sent me out a new unichip and harness overnight.I got the car running the following day and have had no prolems with the kit.This kit is good for those that want some added power without goin broke and it is very upgradable.I heard some people having some problems with Alpine before but I can't say the same.I was updated thru out the entire time about how my kit was coming along and whenever I had a question it was answered promptly.
Converse
 

·
Registered
Joined
·
9,504 Posts
Gary2 said:
Thats Great to hear.

Alpine makes some very well built products with customer service to back up the products!
What do you drive a Tiburon? What psi is your tubo and did you have slicks on your track run?
 

·
Retired Staff | Track Rat
Joined
·
5,714 Posts
You didn't have any manifold fitment issues?

Looks fantastic man, congrats on t3h b00st!
 

·
Registered
Joined
·
551 Posts
Discussion Starter #8
MrPhotoman said:
Your engine looks great! When do you plan to dyno and hit the track?
Probably this spring.
Gamz-no manifold fitment issues but I did have a problem with the wastegate actuator hitting the trans bellhousing.A lil grinding down of the bellhousing did the trick
 

·
Registered
Joined
·
8,088 Posts
Hmm... strange. We test fit each and every kit on a engine/tranny combo we have at the shop. I wonder if its just minor manufactoring tolerances with the bell housing. Either way it was my pleasure to help you experience the pleasure of BOOST!!
Guys, you HAVE TO get your Tiburon boosted. That's the ONLY true way to experience how the car should've come from the factory. Stock just does not bring out the true potential of the car. Plus there's nothing like spending a couple grand on a turbo kit and spanking the pants out of cars that cost 3 times a much.
 

·
Retired Staff | Track Rat
Joined
·
5,714 Posts
dmdicks said:
Hmm... strange. We test fit each and every kit on a engine/tranny combo we have at the shop. I wonder if its just minor manufactoring tolerances with the bell housing. Either way it was my pleasure to help you experience the pleasure of BOOST!!
Guys, you HAVE TO get your Tiburon boosted. That's the ONLY true way to experience how the car should've come from the factory. Stock just does not bring out the true potential of the car. Plus there's nothing like spending a couple grand on a turbo kit and spanking the pants out of cars that cost 3 times a much.

You tease!!!!!!!!!

Oh so soon........
 

·
Registered
Joined
·
1,835 Posts
Congrats on the new Turbo setup! Enjoy! :D:D


Gamz said:
You tease!!!!!!!!!

Oh so soon........
^^^^^Official NT.com turbo procrastinator....;)

-BRR
 

·
Registered
Joined
·
551 Posts
Discussion Starter #12
I love it.I need to order the gauges and stuff now.I havent got on her too much because I can't see whats goin on with it without the gauges.Hopefully will order them first part of next week.Although I noticed today I got on it hard and at 60 mph it felt like it hit a wall and lost power and came up with a cyl 1 and cyl 2 misfire.Oh the joys.I had the High Scan in the car with me and couldn't access the freeze frame data because it had cleared from a present fault to a history fault.So on the quest goes
 

·
Registered
Joined
·
656 Posts
I'm having the same problem, especially now that its gotten colder-->misfire cylinder 1. I'm picking up an MSD DIS 2 unit this winter so im hoping that will solve the problem.
 

·
Premium Member
Joined
·
3,168 Posts
Cold weather=overboosting....I see anywhere from 1-3psi jump in boost depending on air temps. Try backing off your psi by 1-2psi and you will be back to normal.
 

·
Registered
Joined
·
656 Posts
Red2.0Tib said:
Cold weather=overboosting....I see anywhere from 1-3psi jump in boost depending on air temps. Try backing off your psi by 1-2psi and you will be back to normal.
Ya its pretty nasty here right now, i've got a decent winter beater so it'll probably just stay in the garage for most of the winter....but still thanks tip.
 

·
Registered
Joined
·
36 Posts
how does the car pull ,and is it worth it because i was also looking into purchasing that kit......but i'm torn between that or the supercharger.....right now i have fujita cai and mussa dual exhaust on the way.....
 

·
Registered
Joined
·
551 Posts
Discussion Starter #19
suspected one said:
how does the car pull ,and is it worth it because i was also looking into purchasing that kit......but i'm torn between that or the supercharger.....right now i have fujita cai and mussa dual exhaust on the way.....
Dude def go turbo.The s/c for our engine is not as upgradable as the t/c.
 

·
Registered
Joined
·
71 Posts
so I read through the whole thread over this Alpine turbo kit. Does it fit the 2000 2.0? The pic in the first post looks the exact same as my motor but mine isn't turbo yet.

Also... I haven't looked it up or anything but what is cvvt?

I have a OBX turbo manifold for a t3/t4 turbo already. I had the head to my 98 Tiburon out, that has the same motor as my 00 and the manifold didn't line up to the bolts. Should I just go ahead and forget that manifold and get the alpine set up? I'd like to boost around 12psi to start. My friend is at 24 right now and his car is INSANE!!! Let me know!
Later,
D
 
1 - 20 of 24 Posts
Top