Hyundai Tiburon Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,690 Posts
Discussion Starter #1
Ok so i went out and tried to start my car and when i turn the key it makes like a machine gun noise underthe hood (im guessing its the starter trying to start) but it wont start is it the battery?
 

·
Registered
Joined
·
547 Posts
It could be the battery or the starter solonoid, even maybe a flat spot on the starter. Someone else will give you more input but those are my guesses.
 

·
Registered
Joined
·
981 Posts
120? my battery died 3 days ago and i went to autozone and exchange it for a new one, paid a $24 difference
 

·
Registered
Joined
·
2,172 Posts
get it tested, itll tell you. or take out the battery from another car hook it up and try (im sure you or somone you know has one redily accesible), if it starts right up then you have a bad cell and it needs to be replaced, this time around i DO SUGGEST A yellow top or redtop (had mine in MULTIPLE cars in the past for 3 years and has never let me down)
Chase
 

·
Registered
Joined
·
1,690 Posts
Discussion Starter #8
Yap it was the battery. I bought a red top and it starts great. unfortunately ive run into some other issues so im still not going to get to make it to the track today major suckage. Of course the car runs perfect until the 1st chance I have to get it to the track then everything goes wrong. anyway thanks everyone got that problem out of the way
 

·
Registered
Joined
·
2,172 Posts
whats wrong with it???
Chase
 

·
Registered
Joined
·
1,690 Posts
Discussion Starter #11
ShrkByt05 said:
whats wrong with it???
Chase
my a/f ratio is FUBAR and i dont know why, I havnt changed anything. Its fine until 5K then it just goes crazy. Its so off that the car stalls out. Oh well guess that gives me a project for my next day off
 

·
Registered
Joined
·
1,690 Posts
Discussion Starter #12
gamingdexter said:
wait so whats the difference between a yellow top and a red top battery? do they help with performance as well as the stereo?
Theres a big diffrence search and youll find it
 

·
Registered
Joined
·
4,295 Posts
more info?

we've both run into electrical problems :( At least i know mine is in limp mode
 

·
Registered
Joined
·
1,690 Posts
Discussion Starter #14
Zaion said:
more info?

we've both run into electrical problems :( At least i know mine is in limp mode
whats limp mode?

Well thats about all there is to it my battery was dead then when i replaced it i started to drive out to the track decided to give it full throttle down this road and when it hit 5K things just went to hell tried it a few more times with the same result. Also my a/f used to make a wave pattern at low throttle and now its just a flat line (rich the whole time) Its very weird and out of the blue.
 
1 - 14 of 14 Posts
Top