Hyundai Tiburon Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
okay so heres the deal...something is going on with my clutch/tranny. when i have my foot on the clutch pedal the car is slowly moving forward if i am in gear like it is not fully disengaged. Also as i am driving i have to slam my foot down on the pedal and rip through the gear to get in from one to the other. now i only drove like this for about 3 miles and the car has been sitting in my garage since but anyone have any idea what might cause this? im planning on going to get the line bled and new fluid put in it to see if that helps.. but has anyone else had this at all? slave, master or clutch? let me know if you have the slightest idea b/c the car just expired on the warranty (i didnt get the 100k, i know i should have:3_saai: ) and im only 18 so i dont have thousands of dollars to be throwing out on this just to let a mechanic run up the bill. let me kno what you guys think....i really appreciate it.
 

·
Registered
Joined
·
495 Posts
You're clutch is toast. I experienced the same thing at work a few months ago on a Dodge 2500 diesel. I had the clutch all the way down and when I shifted into gear to pull the truck out, I had to keep my foot on the brakes to keep the truck from moving. I also had to force the shifter to shift out of gear.
 

·
Registered
Joined
·
843 Posts
Your Preasure plate is shot and the clutch isnt disengaging - I would stop driving it period because you ramming through the gears with power running in the driveline will totaly mess up your tranny.
 
1 - 4 of 4 Posts
Top