Hyundai Tiburon Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3,978 Posts
Discussion Starter · #1 ·
sup ppl im here in desperate need of help. i bought this exact double din headunit in September http://cgi.ebay.com/D-1041-6-5-DOUB...4QQihZ020QQcategoryZ67771QQrdZ1QQcmdZViewItem
. coming home last night i had a dvd data disc on it. listening to music it suddenly stopped n said disc err. i took it out and put it back in, same thing disc error. then i tried a reg movie dvd, disc error. i tried a music cd, it worked. what the hell. 3 audio cds later it doesnt read those either. now it displays "no disc" for all discs. i go to the manual and on troubleshooting it says "disk can not be read, 3.the optical head has the dew". 3. "press the power button, take the disk out, lay it on the table about 1-2 hours"

this is word for word what is says on the manual. wtf is the dew n lay it on the table. these *** *** chinese translated manuals dont make sense.

does anyone know what the prob is here. or do i just need a new double din grrr
 

·
Registered
Joined
·
673 Posts
I think there was a thread on this site a while back on buying "cheap headunits" Not trying to dis you in any way, but you bought a headuit that was a third of the price of a decent one. IMO im surprised you lasted this long.
Im a firm beliver in "you get what you pay for" if it seems like it was way to good to be true...it most like is.
You can try to get a disk cleaner after it, or take it apart and let it air out, becuse what the manual most likely means is that the lense got condensation on it.
 

·
Registered
Joined
·
3,978 Posts
Discussion Starter · #3 ·
cycon82 said:
I think there was a thread on this site a while back on buying "cheap headunits" Not trying to dis you in any way, but you bought a headuit that was a third of the price of a decent one. IMO im surprised you lasted this long.
Im a firm beliver in "you get what you pay for" if it seems like it was way to good to be true...it most like is.
You can try to get a disk cleaner after it, or take it apart and let it air out, becuse what the manual most likely means is that the lense got condensation on it.

i know man im dont feel dissed whatsoever. i do agree you get what you pay for. i figured this was worth the attempt. i just went n got a lens cleaner, i cycled it but i dont know if it worked or not bc the it says no disc still and, i guess tom ill take it out n see if i can blow dry it or let it dry out. i guess i should add i was driving 12 hrs back from miami so yes it makes sense if humidity got in there while i had the heat n all that. wish me luck this weekend has been of bad luck all over. my sony crt tv of 12 yrs broke today as well. i smashed my glasses, and a tire damaged my lip on the way up. all this in a weekend blah.
 

·
Registered
Joined
·
653 Posts
is it making any noises when you put a disc in? if it's silent, then you have probably got a case of a dead drive. If it sounds like it's trying, your motor might be going out, or it truly is dirty. I have seen a lot of bargain head-units have issues because they just can't buffer and use error correction because of microscopic lint or humidity from the unit itself heating up. Yeah, you get what you pay for, but for the money, I would at least take it apart and check it out (That's assuming you have no warranty or any chance of returning it).
 

·
Registered
Joined
·
3,978 Posts
Discussion Starter · #5 ·
b-dirty said:
is it making any noises when you put a disc in? if it's silent, then you have probably got a case of a dead drive. If it sounds like it's trying, your motor might be going out, or it truly is dirty. I have seen a lot of bargain head-units have issues because they just can't buffer and use error correction because of microscopic lint or humidity from the unit itself heating up. Yeah, you get what you pay for, but for the money, I would at least take it apart and check it out (That's assuming you have no warranty or any chance of returning it).
if i hit the next keys on the unit the dis err comes up but if i do the same thing on my remote itll be like if it is skipping, its just i cant see anything. seems to me theres no warranty since there is no manufacture to go to, but i will take it apart and see what i can come up with. in all honesty the thing was on for 4-6 hrs before it gave up n that makes sense bc it was from humid fl to cold north carolina, so im hoping thats what it is
 
1 - 5 of 5 Posts
Top