Hyundai Tiburon Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
633 Posts
Discussion Starter #1
suddenly tonight while driving i noticed my reverse lights were still on even though i was driving forward. to make it even more weird i noticed that the only way i could get them off was in 2nd gear above 3000rpm and accelerating--but the second i let off gas the reverse lights went back on...finally i yanked the fuse out, but its so weird cause i havent messed with anything lately it just all of a sudden started happening...hoping its a freak reaction to weather....i have had other strange lighting issues, maybe they are all related, my rear passenger side repeater tail light thingy went out for acouple days and has since been back on--for good i think...

any and all help is welcome....
 

·
Registered
Joined
·
2,092 Posts
Warranty ftw! Get that baby into the dealer! I had the opposite problem -- mine wouldn't come on, so I took it in and they found out that a switch/relay went out. They ordered the part to have it fixed ...covered under warranty, of course.
 

·
Registered
Joined
·
182 Posts
I had this same problem twice in a years time. Mine wouldnt shut up. Warranty covers it.

Warranty ftw! Get that baby into the dealer! I had the opposite problem -- mine wouldn't come on, so I took it in and they found out that a switch/relay went out. They ordered the part to have it fixed ...covered under warranty, of course.
 

·
Registered
Joined
·
4,770 Posts
It can't be a relay because there's not a relay in that circuit.

Power flows from the battery (power source), through the 10 amp, #3 fuse in the BCM fuse box, then through the "reverse lamp switch" in manual transmission-equipped GK's, returning to the BCM, then to each reverse light, and then finally to ground.

Relays are typically used to control high-current circuits. 10A circuits like the reverse light circuit generally do not require a relay.

In any case, I can almost assure you that you have a faulty reverse light switch.
 

·
Registered
Joined
·
4,770 Posts
Well, I was going to pull up the info on www.hyundaitechinfo.com and copy the pic over here, but it must be acting up or something.

Simply put, whether automatic or manual, the reverse light switch is on top of the transmission. It bolts into the transmission casing on top, usually black in color, and has a connector plug into the top of it.
 

·
Registered
Joined
·
633 Posts
Discussion Starter #12
All right I'll try to help him out with it, unless... KIRBY? YOU THERE?.... he can solve it himself.

Thanks! :)

good lookin out PJM! im goin to DICK dean 2mrrw to see if they'll cover it under warranty...update when i get back....
 

·
Registered
Joined
·
633 Posts
Discussion Starter #14 (Edited)
update:

took it in and DICK dean said revo switch crapt out and it was covered...yay....part not in stock....fail...



Can someone post a pic of the location of the switch and maybe a part number (laziness? lol)



I haven't seen my reverse lights in 6 months or so..... lol. I don't really mind either. I just back park everywhere.
i'll see if i can snap some pics when im getting it replaced.....stay tuned....either 2mrrw or monday ill take it in again....
 

·
Registered
Joined
·
633 Posts
Discussion Starter #16
=================================================================

alrighty here is the conclusion...

it was the reverse lamp switch which is on top of transmission that went bad. for my model, at least, it is part #93860-39003 (2006 gt 5spd)
this part screws in and takes about .768 minutes to change.
first pic is to help u get your bearings on where in engine the closer up pic is...green circle is slave cylinder and red is revo switch
second pic is the close-up
third and fourth are of the actual switch...had to take pics fast as for some reason they didnt want me to take pic of it so sorry its a lil fuzzy but you get the idea...

=================================================================
 

Attachments

·
Registered
Joined
·
633 Posts
Discussion Starter #18
Did i already give you rep for this AWESOME fix?

dunno....

we just had good timing on this one! seems like giving rep is kinda difficult sometimes but always welcome....hope it helped...not sure if part# is different for other years but a dealer should be able to set u up proper. :3_pimatyo
 

·
Registered
Joined
·
37 Posts
dunno....

we just had good timing on this one! seems like giving rep is kinda difficult sometimes but always welcome....hope it helped...not sure if part# is different for other years but a dealer should be able to set u up proper. :3_pimatyo
Do you have to disconnect the battery, or can you just swap the part out? I have the same issue - lights won't go out.
 

·
Registered
Joined
·
495 Posts
Hate to bump and old thread, but does anyone know the socket size on this sensor?
To say that it simply "screws in" is a bit of a misnomer when it comes to removing this little sucker.
 
1 - 20 of 23 Posts
Top