Hyundai Tiburon Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
hey
my buddies 06 tiburon GT -V6 with 52k miles stick

we were sitting at a traffic light today in neutral with his foot on the brake... he looks up and is like what the hell is this...

his cars tach was at 2k rpm... and not just the gauge.. we could hear the engine actualyl idling at 2k rpm.. he reved it and it went back down to about 800..


anyone have this problem? know a solution? im guessing theres a reason his throttle body is stuck open....?

considering the car is NOT drive by wire.. im guessing im going to be told to check the cable....

any advice is appreciated. Thanks,
 

·
Registered
Joined
·
423 Posts
I have a new 08 and ever since i bought it it idle's higher than 1k normally between 1k and 1.5k
 

·
Registered
Joined
·
560 Posts
mine does this too from time to time, not sure why
 

·
Registered
Joined
·
1,796 Posts
Prob a dirty MAF or TB
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #5 ·
I have a new 08 and ever since i bought it it idle's higher than 1k normally between 1k and 1.5k
no no.. its not a high idle.. i know a high idle.... like on a cold day... this is just.. as if someones holding the gas pedal perfectly at 2k rpm.. it was so weird to see...
 

·
Registered
Joined
·
495 Posts
More than likely the cable or the tps, as others have said. Take a voltmeter to the tps and see what yout voltage is reading at. Could be bad
 

·
Registered
Joined
·
425 Posts
SOMETIMES when im driving and i put it in neutral and release the gas....it wont drop back down..it will drop to 2.3k and sit....I have to cut it off and on once or twice for it to work right and test it by reving it to about 3000. Had my fuel injection cleaned and it was fine for about a month..now it does it sometimes....it is really pissing me off
 

·
Registered
Joined
·
111 Posts
Ya I have this happen the odd time as well in my 03 GT. It only usually happens when I drive through the city after a long period of time on the highway. Doesn't happen often but like most of you it pisses me off
 

·
Registered
Joined
·
128 Posts
Check for vacuum leaks, especially if any of you have fiddled around with anything lately. I took off my IM and didn't replace the gasket. I idled high and my rpms would stick with my foot off the gas.

To do this start your car, let it idle, shoot brake cleaner around the IM, vacuum lines, etc. If the engine revs up during any particular sprays, you've found your leak. Often, it's as simple as tightening down a loose clamp.
 

·
Dedication to Thai Cuisine
Joined
·
7,687 Posts
also try cleaning out your idle air control valve.
 

·
Registered
Joined
·
4,846 Posts
More than likely the cable or the tps, as others have said. Take a voltmeter to the tps and see what yout voltage is reading at. Could be bad
No. TPS is Throttle Position Sensor, just that, a sensor. It can't move your throttle cables. Throttle cables don't really move on their own, either.
Check for vacuum leaks, especially if any of you have fiddled around with anything lately. I took off my IM and didn't replace the gasket. I idled high and my rpms would stick with my foot off the gas.

To do this start your car, let it idle, shoot brake cleaner around the IM, vacuum lines, etc. If the engine revs up during any particular sprays, you've found your leak. Often, it's as simple as tightening down a loose clamp.
Yes. Especially if you tap the gas and it goes away. Let me guess, your RPM's are also sluggish to go back to idle after revving?
also try cleaning out your idle air control valve.
oye vey...
REPLACE THROTTLE BODY!! I'll say it over and over again. The butterfly valve inside is probably worn.
Do what? How would it wear? It doesn't even slide again anything. I've never heard of this even happening...
No offense, but I would start small and then work my way up to something like that. That can be a $300 repair, easy...
Again, it's probably a vacuum leak. Have you done anything to your car recently?
 
1 - 16 of 16 Posts
Top