Hyundai Tiburon Forums banner

1 - 20 of 30 Posts

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #1 ·
over the weekend I put ssautochrome headers on my 08 tib gt v6 has anyone had the problem of having the rear header hitting the oil pan it went on and sealed fine but the bottom flange is tight to the lip of the oil pan and seems very close to the alternator on one side and then the shift cables on the other side (like 1/4 inch of clearance from either) in the rear of the engine anyone else have these problems with these headers? or had any melted cables or alternator failures due to the heat. thanks.
 

·
Registered
Joined
·
260 Posts
I bent the edge of the oil pan to make it fit.

I have these same questions as well. Though I did move everything as far away from the headers as possible. The alternator does touch the header.
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #3 ·
mine doesnt touch the alternator it has a 1/4 inch clearance or so but I did bend the oil pan too
 

·
Registered
Joined
·
37 Posts
I had a problem also. I notched the lip of the oil pan. Alternator is close but it works fine. o2 sensors tight against starter.
 

·
Registered
Joined
·
6,861 Posts
The headers vary, but I also have tight clearence between the oil pan, but not so bad by the altenator.
 

·
Registered
Joined
·
260 Posts
How did you get the front bottom O2 sensor in there? Mine looks ridiculously tight, so I left it out.
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #7 ·
How did you get the front bottom O2 sensor in there? Mine looks ridiculously tight, so I left it out.
mine is against the sheild of the started But it went in and works i was thinking of bending the sheild to get clearance
 

·
Registered
Joined
·
1,341 Posts
They didn't put the O2 bungs in the exact same spot of all the headers. With the altenator you can break some of the plastic cover that hits the header to gain clearance.
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #9 ·
They didn't put the O2 bungs in the exact same spot of all the headers. With the altenator you can break some of the plastic cover that hits the header to gain clearance.
Yeah i had to relocate the 02 sensor on the rear bottom header it was on the wrong side for the 08 I had to add like 1 ft onto the wire harness for it to loop the the other side of the header.
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #11 ·
You throw any cel's? I've got one but I also have that one O2 sensor hanging unconnected.
no everything runs great you just have to make sure when you add the length of harness you splice the right white wires together because ther are 2 whites a gray and a black so when you cut the original you mark one of the wires on BOTH sides of the cut so you know which one to goes to which
 

·
Registered
Joined
·
7,474 Posts
When i did mine, we had to cut the plastic shielding off of the alternator it doesn't affect anything but makes it a perfect fit after for the SSA headers.

try that and see if that clears up your problem
 

·
Registered
Joined
·
652 Posts
mine was tight but worked. im concered about the alternator. the top bolt that holds the plastic in is rubbing. i bent it up hopefully to make less contact to no avail. like if it rains it will squeek at low rpms. im thinking someday ill pull it out and cut it off. you think it might rub a hole in my headers?
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #14 ·
mine was tight but worked. im concered about the alternator. the top bolt that holds the plastic in is rubbing. i bent it up hopefully to make less contact to no avail. like if it rains it will squeek at low rpms. im thinking someday ill pull it out and cut it off. you think it might rub a hole in my headers?
it might i solved the o2 sensor prob i just hit the starter sheild with a punch and it was fine just a little dent. but i cant grind enough off the header flange to make it not hit the oil pan it seems ok but i wondered if the header flange touching the pan will heat up the oil inside too much? anybody have any ideas or advice? is it even anything to worry about?
 

·
Registered
Joined
·
3,431 Posts
You throw any cel's? I've got one but I also have that one O2 sensor hanging unconnected.
I really hope that your not driving around with your sensor 1 hanging out, because that is one of the sensors that helps control air fuel ratio. That would be very bad for your engine
 

·
Registered
Joined
·
502 Posts

What are you guys running for catbacks and how do you like the sound. I have OBX headers and catback with a test pipe and I think I need a cat. Does anybodies sound like crap from the inside and great outside?
 

·
Premium Member
Joined
·
7,224 Posts
Discussion Starter · #17 ·
I am still running the stock catback because mine hasnt come in yet but it does sound good at idle but between 3000 and 4000 rpms i get a strange sound it goes from a low rumble to like a metallic type of sound and goes away after lie 3800 rpms nothing is rattling loose ar anything but i do have a strait pipe with no cat is this the cause of the sound? if so I have to get a cat too.
 

·
Registered
Joined
·
19 Posts
Is'nt ss autochrome the cheap ebay parts? I have not heard anything good from their turbo kits and manifolds. I know for hondas/acuras they are garbage. Are ya'll having problems with ss auto crap? Ive never had a good experience with them on different cars
 

·
Registered
Joined
·
3,431 Posts
Is'nt ss autochrome the cheap ebay parts? I have not heard anything good from their turbo kits and manifolds. I know for hondas/acuras they are garbage. Are ya'll having problems with ss auto crap? Ive never had a good experience with them on different cars
No ssa is a company, there are copies of ssa on ebay, but there is nothing wrong with ssa except for minor fitment issues, quality is fine.
 

·
Registered
Joined
·
1,378 Posts
I got my headers on about about 10 days ago. The flange near the oil pan does hit. I tried to bend the lip of the pan out of the way, but it didn't work. The pressure forced the flanges to not line up perfectly and resulted in an exhaust leak.

Once I get some new gaskets, I'm going to grind down the flanges a bit and clean up the edge of the oil pan.

I had no issues with alt. clearance.
 
1 - 20 of 30 Posts
Top