Hyundai Tiburon Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone, I have recently installed a stage 0 sniper supercharger on my v6, and it is having a lot of trouble maintaining a steady idle. I was under the impression that you do not need any sort of supporting mods for this, as it can go on a stock engine. I have been running the car on regular gasoline. Could that be the issue? Could it have something to do with a vacuum leak somewhere? I'd really like to get the car back on the road as soon as possible. Thanks for the help!
 

·
Registered
Joined
·
71 Posts
I don't have experience with superchargers, but have you tried higher octane gas? I'm pretty sure they call for premium, I know mine has a slightly rougher idle with regular. Other than that, more info will help once people who do know about this come along. Any codes? Is it possible you swapped some plugs? The IAC connector is identical to another nearby connector (TPS? I can't remember), and that would definitely cause a rough idle. As far as vacuum leaks go I'd expect to see a CEL and some codes to go with it, but if its a small leak who knows.
 

·
Registered
Joined
·
406 Posts
Are you using the stock throttle body? also make sure you didnt switch the plug for the IAC valve and TPS sensor. It could be a vacuum leak. What i had to do tho when i installed my stage 0 i had to make a plate to attach the stock throttle body to the supercharger because the hole for the stock throttle body is i think like 58mm and the hole on the supercharger is 70mm. so if you mounted the stock throttle body straight to that then you IAC will not work right
 
1 - 4 of 4 Posts
Top