Hyundai Tiburon Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
430 Posts
Discussion Starter #1
My friends tib, which everything is stock besides the head unit, has a weird crackling noise come from the speakers.

Thought he probably just blew a speaker but could he have ****ed up on installing it? I've heard that a bad ground wire can cause this too....

Basically his music sounds fine...then after about 5 minutes the speakers go and crackling starts...the more you let it go the louder it gets.

Shut the car off for awhile and goes to turn back on and it works...untill about 5 minutes afterwards.

Thanks for the help
 

·
Registered
Joined
·
1 Posts
Mine did that too, and it turned out to be the battery.. It started with the crackling and then the car started hesitating to start, and the clock resetted everytime I started it..
 

·
Registered
Joined
·
59 Posts
Make sure the wires are properly connected. Make double sure on the power,acc power, and the ground. check your battery voltage, as well as the alternator amperage and volt reading while running.
I'd say get a ground loop isolator, or a noise filter for the power line between the car and radio.(alot of car audio places sell them).

Here is a trusty place to purchase a noise filter: http://www.partsexpress.com/webpage.cfm?webpage_id=3&CATID=35&ObjectGroup_ID=25

oh yeah and try swaping the positive and the negative for that speaker. Speakers are not polarity sensative so don't worry that you'll hurt it. Its just one way sounds better and the other way doesn't

after all that i'd say switch out the radio and see if that helps.
 
1 - 3 of 3 Posts
Top