Hyundai Tiburon Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
561 Posts
Discussion Starter · #1 ·
the NGM man told me what 2 o2 sensors i can leave out of the exhaust but i can rember wich ones he said! any know!
 

·
Registered
Joined
·
561 Posts
Discussion Starter · #4 ·
my tublar header prevent me from installing the o2 on the bottom front one! it will rub on the starter!
 

·
Registered
Joined
·
1,636 Posts
my tublar header prevent me from installing the o2 on the bottom front one! it will rub on the starter!
Yup. Welcome to SSA-style headers. Pretty simple fix tho. I've fixed a number of them now.
 

·
Banned
Joined
·
60 Posts
Take the starter cover off and use a piece of sheet metal cut to fit nicely instead. It will probably be touching, but at least your starter is protected and you have the sensor in.
 

·
Registered
Joined
·
391 Posts
You just have to dent the heat shield that is over the starter. I have pics of it in my journal.
 

·
Registered
Joined
·
561 Posts
Discussion Starter · #8 ·
You just have to dent the heat shield that is over the starter. I have pics of it in my journal.

well ive got everything capped off, where that sensor should be, my only concern is that my car will never adapt or will that rich smell ever go away! thats what ibothers me the most
 

·
Registered
Joined
·
561 Posts
Discussion Starter · #9 ·
i threw my fitst engine light code do u think its because of the o2 sensor not being in the header and just zip tied out , the back rear one is in, but the ftont one is not and its just pluged for now~~:einstein:
 

·
Registered
Joined
·
686 Posts
tibbyfool said:
well ive got everything capped off, where that sensor should be, my only concern is that my car will never adapt or will that rich smell ever go away! thats what ibothers me the most


i threw my fitst engine light code do u think its because of the o2 sensor not being in the header and just zip tied out , the back rear one is in, but the ftont one is not and its just pluged for now
you should definitely simplify the problem by denting the cover and just re-installing the sensor, it creates a mess of things when you try to cut corners man.
 

·
Registered
Joined
·
561 Posts
Discussion Starter · #11 ·
you should definitely simplify the problem by denting the cover and just re-installing the sensor, it creates a mess of things when you try to cut corners man.
i got it istalled again removed the heat shield but i didnt get to get out back in, kinda started raining! i also put the cathc can back to the way it was stock!, reset the ECU and it seems to have worked with what little i did drive it!!!!
 
1 - 11 of 11 Posts
Top