Hyundai Tiburon Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am trying to figure out what's wrong with my 06 tib 2.0 clutch, my car about a year ago just lost all clutch pressure, as I was in process of finding mechanic it just started working properly, about 2 months ago it started losing pressure as I ran through my gears, it got to where after I shift all 5 gears I wouldn't have very much pressure, after few minutes or miles it regained all pressure which stopped me from driving anywhere I had to use clutch alot like traffic lights or just lost of stopping and going, now it's to point where I can drive but I only get to use clutch 3 r 4 times before pressure is gone, yet still I get my pressure back after couple minutes, it has never popped out of gear or slipped, it has never grinded or done anything to make me believe it's the clutch itself, so I am open to any advice or suggestions as without my vehicle I can't hardly gt to work or go to town, I can drive n highway just not where I have to use my clutch rapidly like lights or traffic
 

·
Registered
Joined
·
120 Posts
Clutch master or slave cylinder. As a general rule, if your clutch has trouble disengaging you probably have faulty hydraulics, and if it has trouble engaging, it's probably the clutch disk itself.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Clutch master or slave cylinder. As a general rule, if your clutch has trouble disengaging you probably have faulty hydraulics, and if it has trouble engaging, it's probably the clutch disk itself.
I apologize if this is dumb, I build houses nott mechanic lol, what do you mean by engaging or disengaging, I have no problem shifting gears at all, as far as clutch goes, it's just I can run through my gears like normal bt by time I hit 4 or 5th gear I have almost no pressure but after I drive a few min or miles it comes back with full pressure, or for instance if I hold my clutch down, only hold it down after min or 2 I lose pressure after I left go of pedal, bt again it comes back after a short period of time
 

·
Registered
Joined
·
2,851 Posts
Does sound like either the master or slave cylinder. I'd start by bleeding it really well and possibly changing out most of the fluid if you can and see if that helps. There could be some air trapped in the system or something preventing proper function.

What he means is if you have trouble with the clutch slipping it's probably the clutch disk itself, but problems with the pedal or not letting go of gears or anything like that points to the hydraulics not working like they should.
 
1 - 4 of 4 Posts
Top