Hyundai Tiburon Forums banner

21 - 27 of 27 Posts

·
Registered
Joined
·
271 Posts
I did install an Injen SRI within the last year, and didn't have to pass inspection since then, but I need to do so too.
I am being a bit lazy since my tags expire early September, so I am not in a rush to get it inspected.
 

·
Registered
Joined
·
1,277 Posts
could it be a bad seal on the valves from the snapped timing belt causing the pistons to impact the valves?

also, old rubber may need replacing for evap. new hoses and seals may be needed since i don't think the charcoal canister would die from siting still.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #23
The whole top end was rebuilt when the belt snapped so I dont think it would be a bad valve seal. I will have to look over the evap system and see if I can source parts at a decent price. I pulled out the old upstream o2 sensors to replace them. The old ones came out with some white gunk on them. I believe thats a sign of the car running lean. So I will have to check the plugs as well. I just did that this morning so I will be driving it later today to see if the o2 sensors will ready now
 

·
Registered
Joined
·
14 Posts
Discussion Starter #24
Pulled the plugs and there is no white residue on the spark plugs. They have a nice tan color witch means its good running. Huh. I wonder if it was before the rebuild it was running bad. Well hopefully now it will ready with the new o2s.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #25
Well still doing drive cycles and o2 and evap wont ready. I guess I will be looking thru the evap to see of it is clogged. I did a ecu reset and did a drive cycle. The o2 sensors on my live data look better. The old ones where staying in the .500V-800v and these ones go down to 0.019v-.800v depends on the situation. They match closer to the downstream sensors. So I guess we will see and I will update the fourm as I go. I just need one more sensor to ready to pass.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #26
Thank you @OmarAta . with a combination of that drive cycle and then taking the car 20 mile drive with the o2 sensor change I got the o2 to ready. That just leaves the evap witch means I can go pass my emissions. I am allowed to have one unready and still pass.
 

·
Registered
Joined
·
271 Posts
Thank you @OmarAta . with a combination of that drive cycle and then taking the car 20 mile drive with the o2 sensor change I got the o2 to ready. That just leaves the evap witch means I can go pass my emissions. I am allowed to have one unready and still pass.
same here in Texas, I can have one unready and still pass.
I did manage to get my evap ready when I got my car (after setting for 3 years) by taking the canister out and shaking the hell out of it.
since all the little carbon stuff in it where infused as once giant piece.
 
21 - 27 of 27 Posts
Top